Dictionary lookup is broken / dictionary popup stays blank

RESOLVED FIXED in Firefox 54

Status

()

RESOLVED FIXED
2 years ago
11 days ago

People

(Reporter: mstange, Assigned: mstange)

Tracking

({regression})

Trunk
mozilla55
All
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54+ fixed, firefox55+ fixed)

Details

(Assignee)

Description

2 years ago
Steps to reproduce:
 1. Click on this page to make sure it's focused.
 2a. Hover your mouse over some word in this comment press Cmd+Ctrl+D, or
 2b. Three-finger-tap a word in this comment with your touchpad.

Expected results:
The dictionary popup should appear and show content.

Actual results:
The dictionary popup appears and stays blank.

I broke this in bug 1354715.
Fixed by backing out bug 1354715. Should be in tomorrow's nightly and 54b4.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox54: affected → fixed
status-firefox55: affected → fixed
status-firefox-esr52: --- → unaffected
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
tracking-firefox54: ? → +
tracking-firefox55: ? → +
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1361192

Comment 3

11 days ago
Can we reopen this? It's broken again. Firefox 63.0.1 on macOS 10.14.1.

1) Three finger tap doesn't work for phrases. If a phrase is selected and tapped, Safari will show a dictionary entry for the whole phrase. For example, try looking up "hard sell". Firefox will only look up one word or the other, or if you happen to tap on the space between words, it will try to look up that and show a popup with "No Results Found".

2. Using Cmd+Ctrl+D shortcut results in the same behavior as 1)

3. Nor there is <Look Up "Some Phrase"> entry in the context menu that would allow you to lookup the whole phrase.

I would expect to have 1), 2) and 3) all working for looking up phrases.
(Assignee)

Comment 4

11 days ago
Those are valid bugs, but they are different bugs from this one, which was about a blank panel. Could you file a new bug in Core :: Widget: Cocoa for 1)? It looks like we already have a bug for 3), bug 1116391.

Comment 5

11 days ago
I started doing that but found a bug report for 1) also: 1336426
It doesn't mention 2), so I did.
You need to log in before you can comment on or make changes to this bug.