Loading modules across origins seems to send Firefox into a spin

RESOLVED DUPLICATE of bug 1426140

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1426140
2 years ago
a year ago

People

(Reporter: jaffathecake, Unassigned)

Tracking

({triage-deferred})

Trunk
triage-deferred
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.81 Safari/537.36

Steps to reproduce:

https://cdn.rawgit.com/jakearchibald/2b8d4bc7624ca6a2c7f3c35f6e17fe2d/raw/fe04e60b0b7021f261e79b8ef28b0ccd132c1585/

This page contains two cross-origin module scripts. One has CORS headers, the other doesn't.


Actual results:

The loading spinner keeps on spinning, nothing is displayed.


Expected results:

The script with CORS headers should execute, the other should not.
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
Blocks: 1240072
Keywords: triage-deferred
Priority: -- → P3
(Reporter)

Comment 1

a year ago
Feels like this should be higher than p3, since the result is never-loads, but I guess everyone thinks 'their' bugs should be high priority.
This should be fixed by bug 1426140.
This now works for me in latest nightly.  Can you check?
Flags: needinfo?(jaffathecake)
(Reporter)

Comment 4

a year ago
Yep! Works for me too!
Flags: needinfo?(jaffathecake)
(In reply to Jake Archibald from comment #4)
Great, thanks for reporting this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1426140
You need to log in before you can comment on or make changes to this bug.