[css-align] Fix order of `unsafe`/`safe` keyword wrt alignment keyword

RESOLVED DUPLICATE of bug 1430817

Status

()

RESOLVED DUPLICATE of bug 1430817
2 years ago
a year ago

People

(Reporter: mats, Assigned: mats)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

2 years ago
The CSS Align spec change in https://github.com/w3c/csswg-drafts/issues/1001
affects parsing and serialization of alignment properties that has an
<overflow-position>.

https://github.com/w3c/csswg-drafts/commit/e729b45733c6b6aa49eb3e467f661036a31e13d0
(Assignee)

Updated

2 years ago
Assignee: nobody → mats
(Assignee)

Comment 1

2 years ago
Created attachment 8868098 [details] [diff] [review]
part 1 - [css-align] Move the 'unsafe'/'safe' keyword before the alignment keyword where needed to prepare for restricting the syntax.

(nothing much to see here, feel free to rubberstamp)
Attachment #8868098 - Flags: review?(cam)
(Assignee)

Comment 2

2 years ago
Created attachment 8868099 [details] [diff] [review]
part 2 - [css-align] Allow 'unsafe'/'safe' only before the alignment keyword, not after (per recent css-align spec change). (Gecko part)
Attachment #8868099 - Flags: review?(cam)
(Assignee)

Comment 3

2 years ago
Created attachment 8868101 [details] [diff] [review]
part 3 - [css-align] Allow 'unsafe'/'safe' only before the alignment keyword, not after (per recent css-align spec change). (Stylo part)
Attachment #8868101 - Flags: review?(cam)
I'm not sure what the status is of this bug wrt the spec issues.  Please re-request review if we're fine to go ahead with this now.
Flags: needinfo?(mats)
Attachment #8868098 - Flags: review?(cam)
Attachment #8868099 - Flags: review?(cam)
Attachment #8868101 - Flags: review?(cam)
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(mats)
Resolution: --- → DUPLICATE
Duplicate of bug: 1430817
You need to log in before you can comment on or make changes to this bug.