Closed Bug 1361615 Opened 3 years ago Closed 3 years ago

Coverity report: ​nsFlexContainerFrame::mChildrenHaveBeenReordered is not initialized in this constructor nor in any functions that it calls

Categories

(Core :: Layout, defect, P4)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1361617

People

(Reporter: mats, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: coverity, good-first-bug)

Coverity CID 1221327 Uninitialized scalar field

The field will contain an arbitrary value left over from earlier computations.

In nsFlexContainerFrame::​nsFlexContainerFrame(nsStyleContext *): A scalar field is not initialized by the constructor

135  explicit nsFlexContainerFrame(nsStyleContext* aContext)
136    : nsContainerFrame(aContext, mozilla::FrameType::FlexContainer)
137    , mBaselineFromLastReflow(NS_INTRINSIC_WIDTH_UNKNOWN)
138    , mLastBaselineFromLastReflow(NS_INTRINSIC_WIDTH_UNKNOWN)
   CID 1221327 (#1 of 1): Uninitialized scalar field (UNINIT_CTOR)2. uninit_member: Non-static class member mChildrenHaveBeenReordered is not initialized in this constructor nor in any functions that it calls.
139  {}


===============================

AFAICT, nsFlexContainerFrame::mChildrenHaveBeenReordered is unused and can be removed:
http://searchfox.org/mozilla-central/search?q=mChildrenHaveBeenReordered&case=false&regexp=false&path=
Oops, sorry, I got Bugzilla errors so I ended up submitting this more than once.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1361617
You need to log in before you can comment on or make changes to this bug.