Closed Bug 1361632 Opened 2 years ago Closed 2 years ago

stylo: full support of -moz-appearance

Categories

(Core :: CSS Parsing and Computation, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: hiro, Assigned: hiro)

References

Details

Attachments

(1 file, 1 obsolete file)

-moz-gtk-info-bar
-moz-mac-active-source-list-selection
-moz-mac-disclosure-button-closed
-moz-mac-disclosure-button-open
-moz-mac-fullscreen-button
-moz-mac-help-button
-moz-mac-source-list
-moz-mac-source-list-selection
-moz-mac-vibrancy-dark
-moz-mac-vibrancy-light
dialog
scrollbar
scrollbar-horizontal
scrollbar-small
scrollbar-vertical
window

These are listed in nsCSSProps::kMozAppearanceKTable but not in keyword list of -moz-appearance for stylo.
Assignee: nobody → hikezoe
Status: NEW → ASSIGNED
Ting-Yu, would you mind reviewing these patches?
Now the keyword list for -moz-appearance should have the same values of nsCSSProps::kMozAppearanceKTable (If I am not missing some).

FYI: another try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a17a0ab74104a42f3138d356c81b5ab645344983&selectedJob=96194849

There seems to be some intermittent failures, I guess it's caused by lacks of some properties supports on stylo.

Thank you!
Comment on attachment 8864057 [details]
Bug 1361632 - Support all properties for -moz-appearance.

https://reviewboard.mozilla.org/r/135772/#review138800

::: servo/components/style/properties/longhand/box.mako.rs:2404
(Diff revision 1)
>  ${helpers.single_keyword("-moz-appearance",
>                           """none button button-arrow-down button-arrow-next button-arrow-previous button-arrow-up
>                              button-bevel button-focus caret checkbox checkbox-container checkbox-label checkmenuitem
> +                            dialog
>                              dualbutton groupbox listbox listitem menuarrow menubar menucheckbox menuimage menuitem

This list is not formatted yet, I will format it before I will send a PR.
Changing dependency.
Blocks: 1321769
No longer depends on: 1349651
Comment on attachment 8864057 [details]
Bug 1361632 - Support all properties for -moz-appearance.

https://reviewboard.mozilla.org/r/135772/#review138924

Wow, this is awesome! Great job hiro.
Attachment #8864057 - Flags: review+
Comment on attachment 8864058 [details]
Bug 1361632 - Adjust reftest expectation for -moz-appearance.

https://reviewboard.mozilla.org/r/135774/#review138926

So many passes!
Attachment #8864058 - Flags: review+
Attachment #8864057 - Attachment is obsolete: true
Attachment #8864057 - Flags: review?(tlin)
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6ee8241b984e
Adjust reftest expectation for -moz-appearance. r=bholley
Pushed by ihsiao@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/d19472763d1d
Adjust reftest expectation for -moz-appearance. r=bholley. a=merge
https://hg.mozilla.org/mozilla-central/rev/d19472763d1d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Blocks: 1351978
You need to log in before you can comment on or make changes to this bug.