Closed Bug 1362054 Opened 3 years ago Closed 3 years ago

Turn request-list-header-context-menu.js into a react component

Categories

(DevTools :: Netmonitor, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1336382

People

(Reporter: rickychien, Unassigned)

References

Details

(Whiteboard: [netmonitor])

There are some leftovers modules living in src folder haven't rewrite yet. request-list-context-menu.js should turn into a react component and connect to redux store.

Tasks:

* Turn request-list-context-menu.js module into a react component
* Hook up the react component to redux store by calling react-redux's connect()
No longer depends on: 1344160, 1358054, 1344158, 1356957, 1358715
Summary: Turn request-list-context-menu.js into a react component → Turn request-list-header-context-menu.js into a react component
There's bug 1336382 about request list context menu
ha! I almost forgot I reported a bug for this. There is another one for header-context-menu (see bug 1362059). Let's close this.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1336382
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.