Closed Bug 1362207 Opened 3 years ago Closed 3 years ago

Remove the dropdown menu from the footer of the Downloads Panel

Categories

(Firefox :: Downloads Panel, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: Paolo, Assigned: Paolo)

References

Details

Attachments

(1 file)

After implementing the dropdown menu in the footer of the Downloads Panel, we found several issues with the behavior of the sub-menu that prevented us from releasing the feature, and would be time consuming and difficult to fix.

In the meantime, the Photon redesign included a new concept for an easily accessible Downloads Library that would not require a submenu:

https://mozilla.invisionapp.com/share/ENBBK0F9U#/screens/229252060

At the time, we kept the feature enabled for Nightly and Developer Edition, but not for Beta. Given that there are no plans to release the feature in the short term, and in the long term we'll have a different design, we should remove the unreleased code.

We can still keep the string "Open Downloads Folder" in the tree with an explaining comment, so it can be reused by the Photon of the feature.
Priority: -- → P2
Duplicate of this bug: 1345383
Duplicate of this bug: 1301708
Duplicate of this bug: 1321712
Duplicate of this bug: 1320259
Wesly, you've probably already seen that the other bugs are now resolved as duplicates. They can be removed from the CHE dashboards, as we'll use Photon Structure tracking to implement the newly designed interface at the appropriate time, which can also be later than Firefox 57.
Flags: needinfo?(wehuang)
Comment on attachment 8864870 [details]
Bug 1362207 - Remove the dropdown menu from the footer of the Downloads Panel.

https://reviewboard.mozilla.org/r/136558/#review140136
Attachment #8864870 - Flags: review?(mak77) → review+
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0931839a3e5b
Remove the dropdown menu from the footer of the Downloads Panel. r=mak
https://hg.mozilla.org/mozilla-central/rev/0931839a3e5b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
(In reply to :Paolo Amadini from comment #6)
> Wesly, you've probably already seen that the other bugs are now resolved as
> duplicates. They can be removed from the CHE dashboards, as we'll use Photon
> Structure tracking to implement the newly designed interface at the
> appropriate time, which can also be later than Firefox 57.

Thanks Paolo for the reminder and Yes, I've noticed those bug status are updated recently and will reflect it in my tracking dashboard, too.
Flags: needinfo?(wehuang)
I can see the fix implemented in latest Nightly 55.0a1 on windows 10, 64-bit

Build ID 	20170516122050
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170517]
You need to log in before you can comment on or make changes to this bug.