Closed Bug 1362828 Opened 4 years ago Closed 4 years ago

mozboot: Fix clang package download message

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(firefox53 unaffected, firefox54 unaffected, firefox55 fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed

People

(Reporter: cpeterson, Assigned: cpeterson)

References

Details

Attachments

(1 file)

Nathan, I think this HTTP 403 Forbidden error really is a permissions problem with the clang tooltool package for Mac. If I alter the URL's hash, the server returns HTTP 404 Not Found, which suggests that the Mac package hash is correct and the file exists on the server.
Flags: needinfo?(nfroyd)
This patch does not fix the HTTP 403 Forbidden problem. It just fixes a typo in mach bootstrap's clang package download message.
Comment on attachment 8865190 [details]
Bug 1362828 - mozboot: Fix clang package download message.

https://reviewboard.mozilla.org/r/136860/#review140108

Whoops!  Didn't look very closely at the printed message, I guess...
Attachment #8865190 - Flags: review?(nfroyd) → review+
Pushed by nfroyd@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3655533be7c7
mozboot: Fix clang package download message. r=froydnj
Pretty sure the 403 is bug 1359968, which is fixed on mozilla-central.
Duplicate of this bug: 1363106
Bug 1359968 updated the tooltool manifests, but `mach boostrap` doesn't read those directly. I've opened 1363110 about propagating the change to mozboot/stylo.py.
Bug 1363110 fixes the Mac clang package hash, so I'll morph this bug into just fixing the download message typo (dupe bug 1363106).
Assignee: nobody → cpeterson
Flags: needinfo?(nfroyd)
Summary: mach bootstrap fails with HTTP 403 Forbidden when trying to download the clang tooltool package for Mac → mozboot: Fix clang package download message
https://hg.mozilla.org/mozilla-central/rev/3655533be7c7
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.