Crash in nsTArray_Impl<T>::Clear | mozilla::ConsoleReportCollector::Release

RESOLVED DUPLICATE of bug 1381362

Status

()

--
critical
RESOLVED DUPLICATE of bug 1381362
a year ago
a year ago

People

(Reporter: marcia, Assigned: dragana)

Tracking

({crash, regression})

55 Branch
Unspecified
Windows 10
crash, regression
Points:
---

Firefox Tracking Flags

(firefox53 unaffected, firefox54 unaffected, firefox55 disabled, firefox56 disabled)

Details

(Whiteboard: [necko-active], crash signature)

This bug was filed from the Socorro interface and is 
report bp-b794d306-6804-4d5f-a9cd-5c6060170507.
=============================================================

Seen while looking at crash stats - crashes started with 20170506030204: http://bit.ly/2piTBRc

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0b255199db9d6a6f189b89b7906f99155bde3726&tochange=37a5b7f6f101df2eb292b1b6baaf1540c9920e20

ni on dragana since she mentioned she landed some networking stuff.
Flags: needinfo?(dd.mozilla)
(Assignee)

Comment 1

a year ago
This does not look my last change has cause it.

This is called from nsProtocolProxyService.cpp.

Daniel, do you know if something change around proxies, there were some bugs but I have not follow them carefully?
Flags: needinfo?(dd.mozilla) → needinfo?(daniel)
Whiteboard: [necko-backlog]
Actually, I think the bug lies in ConsoleReportCollector.
Component: Networking → DOM
Whiteboard: [necko-backlog]
Yes, ConsoleReportCollector is on the stack, but its just a ref counted objected with an nsTArray.  Its unclear to me what it could be doing wrong here.  Also, it hasn't changed in a long time.

It looks to me like the channel being destroyed is not valid.
Dragana, I don't see how you suspect this to be a proxy bug. Can you elaborate?
Flags: needinfo?(daniel)
(Assignee)

Comment 5

a year ago
(In reply to Daniel Stenberg [:bagder] from comment #4)
> Dragana, I don't see how you suspect this to be a proxy bug. Can you
> elaborate?

2 reports I lookedin had something with ProxyService, but not all of them. This is TFO bug cause by antivirus software :(

Sorry for the noise.
(Assignee)

Updated

a year ago
Blocks: 1188435
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
Hi Dragana, are you going to take this regression?
Flags: needinfo?(dd.mozilla)
(Assignee)

Comment 7

a year ago
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #6)
> Hi Dragana, are you going to take this regression?

I am keeping eye on all regression from bug 1188435. That feature is disabled at the moment and crashes are gone.
Flags: needinfo?(dd.mozilla)
(Assignee)

Updated

a year ago
Assignee: nobody → dd.mozilla
Status: NEW → ASSIGNED
(Assignee)

Updated

a year ago
Component: DOM → Networking: HTTP
Whiteboard: [necko-active]
(Reporter)

Updated

a year ago
Flags: needinfo?(mozillamarcia.knous)
TFO was turned on again in Bug 1367390, we will keep these crashes open until Dragana evaluates whether they should be closed or not.
Flags: needinfo?(mozillamarcia.knous)
12 crashes in the 5-31 Windows Nightly, making this the #13 crash for that build.
Since this is a TFO bug I'll move the status flag to 56 and set 55 to disabled.
status-firefox55: affected → disabled
status-firefox56: --- → affected
(Assignee)

Comment 11

a year ago
I am closing this one, signature changed a bit and there is bug 1381362
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1381362

Updated

a year ago
status-firefox56: affected → disabled
You need to log in before you can comment on or make changes to this bug.