Thunderbird does not always load emails (and folders) from gmail account

RESOLVED FIXED in Thunderbird 54.0

Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: paulo, Unassigned)

Tracking

Thunderbird 54.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB54.0b1])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Posted image screenshot.png
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170418123315

Steps to reproduce:

The issue happens very second time I open Thunderbird (also with all addons disabled)

p.s. Running version: 54.0b1 build ID: 20170506000717, on Ubuntu 16.04.



Actual results:

When opening Thunderbird, the Gmail account name is shown in the folder pane, but about every second time I open Thunderbird, it does not show the Gmail folders. After closing and opening Thunderbird again, the Gmail folders are shown again, but when opening a folder, it seems the emails need to be downloaded again.


Expected results:

Opening Thunderbird should show the folders of my Gmail account, and opening a folder should show all emails (without need to download them again).

Comment 1

2 years ago
I get the same results with freshly installed and upgraded Ubuntu 16.04 64-bit (in a VM) and TB 54.0b1 (ID 20170505114636).

The Same thing happens with Daily 55.0a1 (ID 20170509030222) and with Earlybird 54.0a2 (ID 20170509004019) so to me it seems to be directly related with this Ubuntu version.
(Reporter)

Comment 2

2 years ago
To test, I downloaded the beta version from the website (53.0b2 (64-bit)) and ran it without installing (unzip and run by double clicking the executable). Running Thunderbird this way, I do not experience the problems I described above.

Comment 3

2 years ago
Are you using a proxy?

Thunderbird will mark all existing mail and folders "deleted" if it can not complete the sync process with the server.  So things like this are usually network issues,  either proxies and just bad connections.
(Reporter)

Comment 4

2 years ago
No, I am not using a proxy. Also, wouldn't this affect all installs, independent of the version used? With other version there is no problem.

This problem occurs almost always every second time. So if at one time, all folders and messages load / appear, I can be fairly sure the next time they won't. The solution then is simply to close and open Thunderbird again. The folders do not appear instantaneously in such case, they rather appear quickly one after the other (same for the messages if I open a folder). The loading is very fast so I very much doubt that they have to be downloaded again. It is rather as if TB has to index the offline folders and messages again.

Comment 5

2 years ago
I don't use a proxy either. Will it be helpful if I provided a decrypted Wireshark capture to determine whether it is a network issue? I cannot se anything wrong there but honestly I am not really good at reading captures.

Comment 6

2 years ago
I suspect the problem lies with OAuth. Try this.

- In Google account settings enable the "Allow less secure apps" option.
- In Thunderbird, under account's server settings switch "Authentication method" to "Normal password".
- Restart TB a few times (you will need to re-enter your Gmail password) and see whether the problem persists.
(Reporter)

Comment 7

2 years ago
I'll give it a try. But note that I am using OAuth in my current installation, TB version 53.0b2, without any problems
(Reporter)

Comment 8

2 years ago
Tried it using the "Allow less secure apps". Seems to work. Given that the OAuth used to work in TB version 53.0b2, this is a regression in this functionality?

Comment 9

2 years ago
All I know is that when I examined the communication with Wireshark I saw "Invalid credentials" response on those occasions when this problem happened. Screenshot: https://i.imgur.com/iyII9MM.png

Comment 10

2 years ago
I'm having the same issue, but I'm on Fedora, so it's not just an Ubuntu issue. I originally downloaded the beta using the Thunderbird release channel site, and have been applying upgrades automatically since. Unfortunately, I did the rash thing, and removed the account entirely, and am now re-downloading all my emails again. I'm willing to do more testing once that finishes, though.

Comment 11

2 years ago
Same problem is happening in the Windows version of Thunderbird 54.0b3.  Problem seems limited to Gmail account using OAuth2.  Problem began with 54.0 beta and wasn't present in 53.0 beta.
Hi All. Thanks for the great details in this bug report.

Please see bug 1373161 comment 8 and test the nightly builds please. Thanks.

Updated

2 years ago
See Also: → 1373493

Updated

2 years ago
Component: Untriaged → Networking: IMAP
Product: Thunderbird → MailNews Core
Whiteboard: [regression:TB54.0b1]
Version: 54 Branch → 54

Comment 13

2 years ago
Bug 1373493 is an accurate depiction of this problem for me. Maybe this bug should be marked as a duplicate of that one?

Comment 15

2 years ago
Unfortunately, I cannot confirm a fix, because I am no longer able to reproduce the problem with any of the older versions that I previously had this problem with.

Comment 16

2 years ago
Fixed by backouts from TB 52 and later. Open report remains: Bug 1379475.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 54.0

Updated

2 years ago
Blocks: 1176399
You need to log in before you can comment on or make changes to this bug.