Drop "Legacy" Hint in Add-ons Manager Extensions List

RESOLVED FIXED in Future

Status

--
enhancement
RESOLVED FIXED
2 years ago
2 months ago

People

(Reporter: RainerBielefeldNG, Assigned: frg)

Tracking

SeaMonkey 2.52 Branch
Future
Unspecified
All

SeaMonkey Tracking Flags

(seamonkey2.49esr unaffected, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.60 wontfix, seamonkey2.63 fixed)

Details

(Whiteboard: [easyconfirm])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Steps how to reproduce with unzipped installer of  official  en-US SeaMonkey 2.52a1 (NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0 Build 20170508175137  (Default Classic Theme) on German WIN7 64bit:

1. Launch SM
2. Menu ˋTools → Add-ons Manager - Extensionsˊ
   » List of installed extensions appears with "Legacy" hint for all
     add-ons which ar not based on webextensions 

For SM this hint is useless
(Reporter)

Updated

2 years ago
Severity: normal → enhancement
OS: Unspecified → All
(Reporter)

Updated

2 years ago
Whiteboard: [easyconfirm]
(Assignee)

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

2 years ago
Flags: needinfo?(frgrahl)

Updated

4 months ago
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1373375

Updated

4 months ago
Flags: needinfo?(frgrahl)

Comment 2

4 months ago
Sorry, tested with the wrong version. Therefore not a duplicate.
Status: RESOLVED → REOPENED
Flags: needinfo?(frgrahl)
Resolution: DUPLICATE → ---
(Assignee)

Updated

3 months ago
Assignee: nobody → frgrahl
Status: REOPENED → ASSIGNED
status-seamonkey2.49esr: --- → unaffected
status-seamonkey2.53: --- → affected
status-seamonkey2.57esr: --- → affected
status-seamonkey2.60: --- → wontfix
Flags: needinfo?(frgrahl)
(Assignee)

Comment 3

3 months ago
Created attachment 9024277 [details] [diff] [review]
1365170-NoLegacy.patch

Simple fix. 1:1 copy from TB. I thought about displaying Classic instead of Legacy but supressing it works fine for now.
Attachment #9024277 - Flags: review?(iann_bugzilla)
Attachment #9024277 - Flags: approval-comm-esr60?

Comment 4

3 months ago
Comment on attachment 9024277 [details] [diff] [review]
1365170-NoLegacy.patch

LGTM r/a=me
Attachment #9024277 - Flags: review?(iann_bugzilla)
Attachment #9024277 - Flags: review+
Attachment #9024277 - Flags: approval-comm-esr60?
Attachment #9024277 - Flags: approval-comm-esr60+

Comment 5

3 months ago
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/5e5555a83f3b
Drop "Legacy" Hint in SeaMonkey Add-ons Manager Extensions List. r=IanN
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago3 months ago
Resolution: --- → FIXED
(Assignee)

Comment 6

3 months ago
https://hg.mozilla.org/releases/comm-esr60/rev/12d0494de6aa21983a00c5db3938ed753dc0433c
status-seamonkey2.57esr: affected → fixed
Target Milestone: --- → Future
(Assignee)

Updated

2 months ago
status-seamonkey2.63: --- → fixed
You need to log in before you can comment on or make changes to this bug.