Page jumps to the beginning after reload with open developer tools

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
2 years ago
6 months ago

People

(Reporter: bt3, Unassigned)

Tracking

({regression})

53 Branch
Unspecified
Windows
regression

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox-esr52 unaffected, firefox53 wontfix, firefox54 fix-optional, firefox55 wontfix, firefox56 wontfix, firefox57 unaffected, firefox58 unaffected)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170504105526

Steps to reproduce:

The developer tools are open and I have scrolled the page down. Now I make a reload (e.g., F5).


Actual results:

The page jumps back to the beginning and I have to scroll back to the location I checked before. When the developer tools are closed the jump does not happen.


Expected results:

Scrolling down again and again is very annoying during development. Better if the page stands at this point even if I make a reload.
(Reporter)

Updated

2 years ago
Summary: Developer Tools Reload → Page jumps to the beginning after reload with open developer tools

Comment 1

2 years ago
Cannot reproduce the problem in Firefox 53 on Fedora on this very page. Does this also happen with a fresh profile and add-ons disabled? Which OS etc?
Flags: needinfo?(bt3)

Comment 2

2 years ago
I can reproduce the problem on Win10 Nightly55 as well as Firefox53 if I opened Inspector.
The problem does not occur on Firefox52.
Status: UNCONFIRMED → NEW
status-firefox53: --- → wontfix
status-firefox54: --- → fix-optional
status-firefox55: --- → affected
status-firefox-esr45: --- → unaffected
status-firefox-esr52: --- → unaffected
Component: Untriaged → Developer Tools
Ever confirmed: true
Keywords: regression
OS: Unspecified → Windows

Comment 3

2 years ago
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=057d31114af0fdf9488d651a07a1dcc6815d2b1b&tochange=76d437394bf331626b9be6b2dcad8a6fec61979a

Regressed by: 4c0d4f924023	J. Ryan Stinnett — Bug 1341756 - Clear any highlighters on window-ready. r=zer0
Blocks: 1341756

Comment 4

2 years ago
@:jryans
Your patch regress this. Could you look this?
Flags: needinfo?(jryans)

Updated

2 years ago
Component: Developer Tools → Developer Tools: Inspector
Not sure I follow why this would make the page jump...  :zer0, what do you think about this?
Flags: needinfo?(jryans) → needinfo?(zer0)
(Reporter)

Comment 6

2 years ago
This also happens with deactivated add-ons (Win7, FF 53.0.2, 32Bit).
Flags: needinfo?(bt3)
DevTools bug triage (filter on CLIMBING SHOES).
Priority: -- → P2
Duplicate of this bug: 1371050
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #5)
> Not sure I follow why this would make the page jump...  :zer0, what do you
> think about this?

My educated guess is that the repositioning of the page will happens only if the document is unchanged, (e.g. bfcache), and since we're changing the the content of the document during the loading that invalidate the action.

I do not have any fix or workaround atm for that, I'm still investigating on platform side.
Flags: needinfo?(zer0)

Comment 10

2 years ago
Hi there!
FYI, this is also happening with Firefox/54.0b14 on macOS (10.12.5), when Dev Tools are opened.
(And so annoying with this blackbox-inspect bug that I switched back to an unnafected version for development).
status-firefox55: affected → wontfix
status-firefox56: --- → wontfix
status-firefox57: --- → fix-optional

Comment 11

a year ago
Precision on this:
I juste discovered that this buggy behaviour disappear when touch events are enabled.
Hope it can help :) (because it's driving me crazy while front-end dev developing with live reload!)

Comment 12

a year ago
This has been fixed for me in FF 57 (latest beta, but probably earlier).
Duplicate of this bug: 1407802
According to investigation in the duplicate bug 1407802, this is fixed in 57 and later.

Please file a new bug if you see the issue come back!
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox57: fix-optional → unaffected
status-firefox58: --- → unaffected
Resolution: --- → WORKSFORME

Comment 15

a year ago
Ow sorry I did not thought this could be resolved but not reported here.
Thanks!

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.