Closed Bug 1365243 Opened 5 years ago Closed 3 years ago

Intermittent test_quit_restart.py TestQuitRestart.test_in_app_restart | IOError: Process killed because the connection to Marionette server is lost. Check gecko.log for errors (Reason: Timed out waiting for connection on localhost:2828!)

Categories

(Testing :: Marionette, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

[task 2017-07-07T15:21:10.321710Z] 15:21:10     INFO -  1499440870313	Marionette	DEBUG	Received observer notification "profile-after-change"
[task 2017-07-07T15:22:17.279729Z] 15:22:17     INFO -  1499440937274	Marionette	DEBUG	Received observer notification "command-line-startup"
[task 2017-07-07T15:22:17.279838Z] 15:22:17     INFO -  1499440937274	Marionette	INFO	Enabled via --marionette
[task 2017-07-07T15:22:17.510605Z] 15:22:17     INFO -  GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
[task 2017-07-07T15:22:19.457099Z] 15:22:19     INFO -  1499440939453	Marionette	DEBUG	Received observer notification "sessionstore-windows-restored"
[task 2017-07-07T15:22:19.586513Z] 15:22:19     INFO -  1499440939580	Marionette	DEBUG	Received observer notification "sessionstore-windows-restored"
[task 2017-07-07T15:22:21.245548Z] 15:22:21     INFO -  1499440941237	Marionette	INFO	Listening on port 2828
[task 2017-07-07T15:22:21.262591Z] 15:22:21     INFO -  JavaScript error: chrome://marionette/content/server.js, line 350: NS_ERROR_SOCKET_ADDRESS_IN_USE: Component returned failure code: 0x804b0036 (NS_ERROR_SOCKET_ADDRESS_IN_USE) [nsIServerSocket.initSpecialConnection]
[task 2017-07-07T15:23:15.572105Z] 15:23:15    ERROR - Failure during harness execution

Not sure how the second try to setup the server socket could cause such a failure, because it shouldn't affect us here at all. But lets see if the patch on bug 1254136 will make any difference here.
Depends on: 1254136
Could be a dupe of bug 1362293. Lets wait for more failure reports.
Clearly depends on bug 1362293.
Depends on: 1362293
The test is currently marked as skipped, and will be re-enabled with bug 1389103.
Depends on: 1389103
Clearly depends on my patch for bug 1410366 too given that this happens after a restart.
Status: RESOLVED → REOPENED
Depends on: 1410366
Keywords: leave-open
Resolution: INCOMPLETE → ---
Assignee: nobody → hskupin
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
The patch on bug 1410366 was not enough here. It's also bug 1433873 which is needed similar to all the other failures for tests in the same file.
Assignee: hskupin → nobody
Status: RESOLVED → REOPENED
Depends on: 1433873
Resolution: FIXED → ---
Target Milestone: mozilla58 → ---
Duplicate of this bug: 1483785
Priority: -- → P5
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.