Kubuntu 16.10 + TB 52.1.1 (64-Bit) + Lightning 5.4 No Date Time Popups

RESOLVED DUPLICATE of bug 1332867

Status

Calendar
Dialogs
RESOLVED DUPLICATE of bug 1332867
8 days ago
3 days ago

People

(Reporter: Tim Reeves, Unassigned)

Tracking

Lightning 5.4

Details

(Reporter)

Description

8 days ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170509205820

Steps to reproduce:

ALL noted software is the current Ubuntu / Kubuntu software packages. Admittedly this may be an issue with KDE SDDM and Co. Anyway: Start to enter a new event, or edit an existing one. Click into the date or time box (begin or end, same [lack of] effect)


Actual results:

Nothing


Expected results:

Up until this update, nice popups appeared allowing easy selection of dates and times.
(Reporter)

Comment 1

7 days ago
It was late at night - now I've noticed more details:

1. The Popups are not gone completely - but they appear when I click (very exactly) on the BORDER of the date or time boxes, rather than on the field itself.

2. Both date and time are always linked, independent of the setting of the "link" icon at the right of the time fields. This makes Lighning completely unusable, as I can't enter an event spanning more than one day.

This is not a fluke at one PC - I have 2 PCs with exactly the same software, it happens at both of them.

So this is a real problem - if I had this software installed at clients who used it commercially - well, you can imagine...

Can someone tell me if Lighning is fetched via the packaging system or is it always fetched from the mozilla repository?

If I download TB for Linux 64bit from https://www.mozilla.org/en-US/thunderbird/all/, I would have to deinstall the package to then install manually - would deinstalling the package also remove my personal TB data?

Thanks!
What is your GTK3 version? Maybe it's bug 1332867 which is not yet in TB 52.
(Reporter)

Comment 3

7 days ago
Thanks for that Richard, looks very much like it (except there is no mention of the other problem I'm seeing that values are linked / autoupdated between begin and end). I'm not sure which of the various GTK packages are relevant, so here's all of them from dpkg:

ii  gir1.2-gtk-3.0:amd64                            3.20.9-1ubuntu2.1                            amd64        GTK+ graphical user interface library -- gir bindings
ii  gir1.2-javascriptcoregtk-4.0:amd64              2.16.1-0ubuntu0.16.10.2                      amd64        JavaScript engine library from WebKitGTK+ - GObject introspection data
ii  gtk-update-icon-cache                           3.20.9-1ubuntu2.1                            amd64        icon theme caching utility
ii  gtk2-engines-oxygen:amd64                       1.4.6-1ubuntu1                               amd64        Oxygen widget theme for GTK+-based applications
ii  gtk2-engines-pixbuf:amd64                       2.24.30-4ubuntu3                             amd64        pixbuf-based theme for GTK+ 2.x
ii  gtk3-engines-breeze                             5.8.5-0ubuntu1~ubuntu16.10~ppa1              amd64        GTK theme built to match KDE's Breeze
ii  kde-config-gtk-style                            4:5.8.5-0ubuntu1~ubuntu16.10~ppa1            amd64        KDE configuration module for GTK+ 2.x and GTK+ 3.x styles selection
ii  kde-config-gtk-style-preview                    4:5.8.5-0ubuntu1~ubuntu16.10~ppa1            amd64        KDE configuration module for GTK+ 2.x and GTK+ 3.x styles selection (extras)
ii  libcanberra-gtk3-0:amd64                        0.30-3ubuntu1                                amd64        GTK+ 3.0 helper for playing widget event sounds with libcanberra
ii  libcheese-gtk25:amd64                           3.22.0-1ubuntu1                              amd64        tool to take pictures and videos from your webcam - widgets
ii  libclutter-gtk-1.0-0:amd64                      1.8.0-1                                      amd64        Open GL based interactive canvas library GTK+ widget
ii  libdbusmenu-gtk4:amd64                          16.04.1+16.10.20160927.2-0ubuntu1            amd64        library for passing menus over DBus - GTK+ version
ii  libgtk-3-0:amd64                                3.20.9-1ubuntu2.1                            amd64        GTK+ graphical user interface library
ii  libgtk-3-bin                                    3.20.9-1ubuntu2.1                            amd64        programs for the GTK+ graphical user interface library
ii  libgtk-3-common                                 3.20.9-1ubuntu2.1                            all          common files for the GTK+ graphical user interface library
ii  libgtk2-perl                                    2:1.2498-3                                   amd64        Perl interface to the 2.x series of the Gimp Toolkit library
ii  libgtk2.0-0:amd64                               2.24.30-4ubuntu3                             amd64        GTK+ graphical user interface library
ii  libgtk2.0-bin                                   2.24.30-4ubuntu3                             amd64        programs for the GTK+ graphical user interface library
ii  libgtk2.0-cil                                   2.12.10-6                                    amd64        CLI binding for the GTK+ toolkit 2.12
ii  libgtk2.0-common                                2.24.30-4ubuntu3                             all          common files for the GTK+ graphical user interface library
ii  libgtkglext1:amd64                              1.2.0-3.2fakesync1ubuntu1                    amd64        OpenGL Extension to GTK+ (shared libraries)
ii  libjavascriptcoregtk-1.0-0:amd64                2.4.11-3                                     amd64        JavaScript engine library from WebKitGTK+
ii  libjavascriptcoregtk-4.0-18:amd64               2.16.1-0ubuntu0.16.10.2                      amd64        JavaScript engine library from WebKitGTK+
ii  libwebkit2gtk-4.0-37:amd64                      2.16.1-0ubuntu0.16.10.2                      amd64        Web content engine library for GTK+
ii  libwebkitgtk-1.0-0:amd64                        2.4.11-3                                     amd64        Web content engine library for GTK+
ii  libwxgtk-webview3.0-0v5:amd64                   3.0.2+dfsg-2                                 amd64        wxWidgets Cross-platform C++ GUI toolkit (webview library runtime)
ii  libwxgtk3.0-0v5:amd64                           3.0.2+dfsg-2                                 amd64        wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
ii  python-gtk2                                     2.24.0-4ubuntu1                              amd64        Python bindings for the GTK+ widget set

Further: How can I change to using a dev version like TB55? Is there a package source (.deb) or would I need to manually install? Or any other way to fix things with less upheaval? [Praise be for phablets and Nextcloud, at least I can work normally there].
Hi Tim, you can download a Daily build from here: http://archive.mozilla.org/pub/thunderbird/nightly/latest-comm-central/
Then you can unpack the tar.bz3 where you want and start thunderbird from this directory. To be on the save side, please make a backup of the .thunderbird directory in your home.

About the linked start/end time there is a chain symbol on the right. Click on it and it should change to a broken chain. Then the times are no more linked.
Flags: needinfo?(receiver)
(Reporter)

Comment 5

4 days ago
Thanks, I just downloaded and unpacked the nightly: thunderbird-55.0a1.en-US.linux-x86_64.tar.bz2

On starting it complained that Lightning did not match the required version and could not find a compatible version - where to get it?

Also (I started from Konsole) I noticed:

-------

messenger.groupdav.overlay.js: failed to include 'chrome://sogo-connector/content/general/sync.addressbook.groupdav.js'
SyntaxError: missing ( after for
File: chrome://sogo-connector/content/general/sync.addressbook.groupdav.js
Line: 473

 Stack:

jsInclude@chrome://sogo-connector/content/addressbook/messenger.groupdav.overlay.js:26:13
@chrome://sogo-connector/content/addressbook/messenger.groupdav.overlay.js:37:1
messenger.groupdav.overlay.js: failed to include 'chrome://sogo-connector/content/general/vcards.utils.js'
SyntaxError: missing ( after for
File: chrome://sogo-connector/content/general/vcards.utils.js
Line: 984

 Stack:

jsInclude@chrome://sogo-connector/content/addressbook/messenger.groupdav.overlay.js:26:13
@chrome://sogo-connector/content/addressbook/messenger.groupdav.overlay.js:37:1
startup from sogo-connector

-------

Anyone have a drop on the SOGo Connector problem?
Flags: needinfo?(receiver)
You have to uninstall the old Lightning. Then the with TB 55 included will be used (maybe you have to enable it after restart).
(Reporter)

Comment 7

4 days ago
Thanks Richard,

I have now downloaded the german version of the nightly build and tried it with the bundled Lightning 5.7:

o The fields to trigger the date and time dropdowns are present and work normally - it was indeed bug 1332867.
o The problem with linked dates/times is resolved as an error in observation on my part.
- I was familiar with chain symbol but had never noticed exactly how it works.
- Seems that to the authors the duration is more important than anything else - the only way to change the duration is by unlinking and changing the end date or time, if I have now observed it correctly. I find the way it is not so intuitive, if I enter a beginn date or time I personally would prefer the end date/time to remain unchanged, but see no way to get that behaviour.

o So in fact the only problem with the stable 52.1 is bug 1332867 - any chance of a backport which would arrive in Ubuntu?
o Sadly I cannot use the daily version as SOGo Connector 31.0.3 does not work with it - Lightning yes but Adress book no, the JS errors prevent it from working. Will look at that and report to SOGo when I have time.

Thanks all!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1332867
(Reporter)

Comment 8

3 days ago
Addendum:

I have just now found SOGo Connector 31.0.4, released recently. It is officially compatible with TB 52. However, it pretty much seems to work with TB 55, the adress book (which was broken on TB55 with SC 31.0.3) works with TB55 + SC 31.0.4.

I am seeing some slightly unnerving Konsole messages:

[calBackendLoader] Using icaljs backend at /usr/local/thunderbird/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/icaljs-manifest
messenger.groupdav.overlay.js: failed to include 'chrome://sogo-connector/content/general/vcards.utils.js'
SyntaxError: redeclaration of let kPhotoImageCache
File: chrome://sogo-connector/content/general/vcards.utils.js
Line: 1

and

this = 5
  this.processMode: 2
  this.pendingOperations: -1
  this.updatesStatus: 2
_checkCallback: processMode: 2
_checkCallback: pendingOperations: -1
sogoWebDAV.js: an exception occured
Buggy situation! (pendingOperations < 0)
undefined:undefined

stack: undefinedurl: https://*hidden*/remote.php/dav/addressbooks/users/*hidden*/aktiv/

Hope this may be of help, Tim
You need to log in before you can comment on or make changes to this bug.