Date/time picker dropmarker is collapsed under recent GTK versions (~ > 3.18 ?)

RESOLVED FIXED in Thunderbird 55.0

Status

Thunderbird
Theme
RESOLVED FIXED
11 months ago
6 months ago

People

(Reporter: Ronan Jouchet, Assigned: Paenglab)

Tracking

(Blocks: 1 bug)

unspecified
Thunderbird 55.0
Unspecified
Linux
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird_esr5254+ fixed, thunderbird53 wontfix, thunderbird54 fixed, thunderbird55 fixed)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

11 months ago
Created attachment 8829163 [details]
dropmarker-before-after-workaround.png

Since a few GTK releases (I think it was 3.18 that introduced the issue), the dropmarkers at the right of the date/time pickers in the new/edit Event dialog are collapsed (into hard-to-click zones of a few pixels wide, see attached screenshot).

Using DOM Inspector, I was able to botch a workaround with this ugly userChrome.css:

    datetimepicker * .menulist-dropmarker {width: 30px;}

To reproduce the issue and implement a proper fix, I guess booting in a VM a livecd for a distro shipping a recent GTK should do the job. Arch, or maybe the latest Fedora?

Configuration
=============

- GTK 3.22.7-1 under Arch Linux
- Standard unmodified GNOME "Adwaita" theme
- Thunderbird 51.0b2 from https://ftp.mozilla.org/pub/thunderbird/releases/51.0b2/linux-x86_64/en-US/thunderbird-51.0b2.tar.bz2
- Lightning 5.3b2 from https://ftp.mozilla.org/pub/calendar/lightning/candidates/5.3b2-candidates/build1/linux-x86_64/lightning-5.3b2.en-US.linux-x86_64.xpi

Comment 1

11 months ago
Richard, would it be possible for you to check if this is a problem with the Lightning default theme?
Flags: needinfo?(richard.marti)
(Assignee)

Comment 2

11 months ago
I see this too in Mail Account Setup -> not a calendar only problem. It's a widget issue but the problem is, m-c uses except in tests no editable menulists and with the old CentOS builders this issue will never be seen in tests.

It's easier to fix this in TB theme as it's very unlikely it will be fixed in toolkit. I'm on a solution (similar to the proposal in comment 0) which doesn't regress on older GTK versions.
Status: UNCONFIRMED → NEW
Component: Dialogs → Theme
Ever confirmed: true
Flags: needinfo?(richard.marti)
Product: Calendar → Thunderbird
Version: Lightning 5.3 → unspecified
(Assignee)

Updated

11 months ago
status-thunderbird52: --- → affected
status-thunderbird53: --- → affected
tracking-thunderbird52: --- → ?
tracking-thunderbird53: --- → ?

Updated

11 months ago
See Also: → bug 1331208
(Assignee)

Comment 3

11 months ago
Created attachment 8830875 [details] [diff] [review]
GTK3dropmarker.patch

This patch shows the dropmarker in Mail Account Setup and datetimepicker but does not regress on older GTK3 versions. Tested on Linux Mint with older GTK3 and Fedora with newer GTK (where no dropmarker was shown before the patch).
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8830875 - Flags: review?(acelists)
(Reporter)

Comment 4

11 months ago
(In reply to Richard Marti (:Paenglab) from comment #3)
> This patch shows the dropmarker in Mail Account Setup and datetimepicker but
> does not regress on older GTK3 versions. Tested on Linux Mint with older
> GTK3 and Fedora with newer GTK (where no dropmarker was shown before the
> patch).

Pasted the patch in my userChrome.css for testing, looks good on GTK 3.22.7 !
Thanks for the fast fix :) , feel free to RESOLVE.

Updated

11 months ago
Blocks: 1313774

Comment 5

10 months ago
Based on comment 2, would there be a chance to fix this properly in toolkit?
Flags: needinfo?(enndeakin)

Comment 6

10 months ago
We can, but it would be better to find out why this was broken. Are we certain that this is a change in GTK3.18?
Flags: needinfo?(enndeakin)
(Assignee)

Comment 7

10 months ago
I can't say it's since GTK3.18 but on Kubuntu 16.10 with GTK3.20 the dropmarker of editable menulists has only a width of 2px.

Comment 8

10 months ago
I do not see the problem on GTK3.18.9, neither in Lightning (5.6a1) nor in new account wizard (TB54).

Ronan, can you retest with current TB? Maybe the issue was already fixed on trunk.
Flags: needinfo?(ronan)
(Reporter)

Comment 9

10 months ago
Created attachment 8836523 [details]
1332867_not-fixed-in-tb54-2017-02-12.png

(In reply to :aceman from comment #8)
> I do not see the problem on GTK3.18.9, neither in Lightning (5.6a1) nor in
> new account wizard (TB54).
> 
> Ronan, can you retest with current TB? Maybe the issue was already fixed on
> trunk.

Testing Thunderbird Daily 54.0a1 (2017-02-12) (64-bit) with a fresh profile, the issue is still present in the New Event dialog. See attached screenshot
Flags: needinfo?(ronan)

Comment 10

10 months ago
And you are on GTK 3.22. Paenglab says it exists in GTK 3.20 already.
So can we wait until I get GTK newer than 3.18 so we see whether it isn't Ubuntu specific?
(Assignee)

Comment 11

10 months ago
It's not Ubuntu specific, I see this on Fedora 25 too.

Comment 12

8 months ago
My distro is testing GTK 3.22 now so I should be able to check this soon.

Comment 13

8 months ago
Comment on attachment 8830875 [details] [diff] [review]
GTK3dropmarker.patch

Review of attachment 8830875 [details] [diff] [review]:
-----------------------------------------------------------------

With Gtk 3.22 this patch is needed and fixes the problem. Can you also fix it in the account creation wizard? File -> New -> Existing mail account .
Thanks
Attachment #8830875 - Flags: review?(acelists) → review+

Comment 14

8 months ago
I know you wanted to fix it TB wide with putting it in messenges.css, but maybe that dialog does not include it.

Updated

8 months ago
Blocks: 1360850
(Assignee)

Comment 15

8 months ago
Created attachment 8863158 [details] [diff] [review]
GTK3dropmarker.patch

Added the rule in accountCreation.css too.
Attachment #8830875 - Attachment is obsolete: true
Attachment #8863158 - Flags: review+
(Assignee)

Updated

8 months ago
Keywords: checkin-needed

Comment 16

8 months ago
This will need uplift as users will run TB52 on the new GTK for the years to come.
(Assignee)

Comment 17

8 months ago
Created attachment 8863159 [details] [diff] [review]
Patch for Beta and ESR

[Approval Request Comment]
User impact if declined: No visible dropmarker with newer GTK versions
Testing completed (on c-c, etc.): ready for c-c
Risk to taking this patch (and alternatives if risky): low
Attachment #8863159 - Flags: review+
Attachment #8863159 - Flags: approval-comm-esr52?
Attachment #8863159 - Flags: approval-comm-beta?
(Assignee)

Comment 18

8 months ago
https://hg.mozilla.org/comm-central/rev/66f479be94c775dabf1da9f595b99f280c84151a
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 55.0

Updated

8 months ago
Attachment #8863159 - Flags: approval-comm-beta? → approval-comm-beta+

Comment 19

8 months ago
Beta (TB 54):
https://hg.mozilla.org/releases/comm-beta/rev/3bbec9a7db8501dd0df4bfaa37be8bc75cb5892a

The patch didn't apply cleanly in messenger.css, please check the result.
status-thunderbird52: affected → ---
status-thunderbird53: affected → wontfix
status-thunderbird54: --- → fixed
status-thunderbird55: --- → fixed
status-thunderbird_esr52: --- → affected
tracking-thunderbird52: ? → ---
tracking-thunderbird53: ? → ---
tracking-thunderbird_esr52: --- → +

Updated

7 months ago
Duplicate of this bug: 1365747

Updated

7 months ago
Attachment #8863159 - Flags: approval-comm-esr52? → approval-comm-esr52+

Comment 21

7 months ago
TB 52 ESR:
https://hg.mozilla.org/releases/comm-esr52/rev/916c12d20362
status-thunderbird_esr52: affected → fixed
tracking-thunderbird_esr52: + → 54+
(Assignee)

Updated

6 months ago
Duplicate of this bug: 1371238
Duplicate of this bug: 1373584
You need to log in before you can comment on or make changes to this bug.