Crash in nsSHEntry::SetSHistory on session restart

RESOLVED DUPLICATE of bug 1363036

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 1363036
a month ago
a month ago

People

(Reporter: tonymec, Unassigned)

Tracking

({crash, regression})

Trunk
x86_64
Linux
crash, regression

SeaMonkey Tracking Flags

(seamonkey2.52 affected)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-704ef730-7fb3-4aae-8cb9-b60190170518.
=============================================================
This crash is new in this nightly AFAICT.
At startup, I see an empty tab instead of the usual saved session. Trying to load the session by means of the Session manager extension produces this crash every time, but not in yesterday's nightly.

Also in bp-ab72ed78-d5b9-4fe1-a96d-1e10d0170518

This crash was in (first known bad):
20170518003001
https://hg.mozilla.org/comm-central/rev/a76d7df3393b5fc4389e8339ac51453a61f6aa61
https://hg.mozilla.org/mozilla-central/rev/baf05f61bc14

Last known good:
20170517003001
https://hg.mozilla.org/comm-central/rev/b7c66885ee8ba0ebeea9a2a241593bf9b28c3af7
https://hg.mozilla.org/mozilla-central/rev/41958333867b

Rather than investigate in more detail, I went back to the 12 May nightly, the last one not affected by bug 1364677.

Feel free to move this bug to a different Product::Component if it seems indicated.

Here comes the Socorro report:

Signature 	nsSHEntry::SetSHistory More Reports Search
UUID 	704ef730-7fb3-4aae-8cb9-b60190170518
Date Processed 	2017-05-18 10:21:04
Uptime 	108 seconds (1 minute and 48 seconds)
Last Crash 	2,388 seconds before submission (39 minutes and 48 seconds)
Install Age 	2,877 seconds since version was first installed (47 minutes and 57 seconds)
Install Time 	2017-05-18 09:32:46
Product 	SeaMonkey
Release Channel 	nightly
Version 	2.52a1
Build ID 	20170518003001
OS 	Linux
OS Version 	0.0.0 Linux 4.4.62-18.6-default #1 SMP Fri Apr 21 16:14:48 UTC 2017 (84f9824) x86_64
Build Architecture 	amd64
Build Architecture Info 	family 6 model 23 stepping 10 | 2
Adapter Vendor ID 	

Adapter Device ID 	

Startup Crash 	

False

MOZ_CRASH Reason 	MOZ_RELEASE_ASSERT(!mShared->mSHistory || (mShared->mSHistory == shistory))
Crash Reason 	SIGSEGV
Crash Address 	0x0
User Comments 	

loading a session
EMCheckCompatibility 	

False

App Notes 	

openSUSE Leap 42.2FP(D00-L1000-W00000000-T000) OpenGL: Intel Open Source Technology Center -- Mesa DRI Intel(R) Q45/Q43  -- 2.1 Mesa 11.2.2 -- texture_from_pixmap
WR? WR- 

Processor Notes 	processor_ip-172-31-15-189_1297; MozillaProcessorAlgorithm2015; skunk_classifier: reject - not a plugin hang

Bugzilla - Report this bug in SeaMonkey Core External Software Affecting Firefox Toolkit
Related Bugs

Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	libxul.so 	nsSHEntry::SetSHistory 	docshell/shistory/nsSHEntry.cpp:971
1 	libxul.so 	nsSHistory::AddEntry 	docshell/shistory/nsSHistory.cpp:388
2 	libxul.so 	NS_InvokeByIndex 	
3 	libxul.so 	XPCWrappedNative::CallMethod 	js/xpconnect/src/XPCWrappedNative.cpp:1996
4 	libxul.so 	XPC_WN_CallMethod 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:982
5 	libxul.so 	js::InternalCallOrConstruct 	js/src/jscntxtinlines.h:293
6 	libxul.so 	js::jit::DoCallFallback 	js/src/jit/BaselineIC.cpp:2447
7 		@0xf8c028b82d2 	
8 		@0x7fd0fe155c0f 	
9 		@0xf8c02b6c2e0 	
10 		@0x7fd109dfab0f 	
11 		@0xf8c02b6c2e0 	
12 		@0x7fd0ec5548f7 	
13 		@0xf8c028ad8a5 	
14 	libxul.so 	EnterBaseline 	js/src/jit/BaselineJIT.cpp:162
15 	libxul.so 	js::jit::EnterBaselineMethod 	js/src/jit/BaselineJIT.cpp:200
16 	libxul.so 	js::RunScript 	js/src/vm/Interpreter.cpp:400
17 	libxul.so 	js::InternalCallOrConstruct 	js/src/vm/Interpreter.cpp:488
18 	libxul.so 	js::Call 	js/src/vm/Interpreter.cpp:534
19 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:2832
20 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/xpconnect/src/XPCWrappedJSClass.cpp:1214
21 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/md/unix/xptcstubs_x86_64_linux.cpp:120
22 	libxul.so 	SharedStub 	
23 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:1302
24 	libxul.so 	NS_ProcessNextEvent 	xpcom/threads/nsThreadUtils.cpp:393
25 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:96
26 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:231
27 	libxul.so 	nsBaseAppShell::Run 	widget/nsBaseAppShell.cpp:156
28 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:283
29 	libxul.so 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:4550
30 	libxul.so 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:4730
31 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:4823
32 	seamonkey 	do_main 	/builds/slave/c-cen-t-lnx64-ntly/build/suite/app/nsSuiteApp.cpp:237
33 	seamonkey 	main 	/builds/slave/c-cen-t-lnx64-ntly/build/suite/app/nsSuiteApp.cpp:311
Ø 34 	libc-2.22.so 	libc-2.22.so@0x206e4 	
35 	seamonkey 	MOZ_CrashPrintf 	/builds/slave/c-cen-t-lnx64/build/mozilla/mfbt/Assertions.cpp:63
36 	seamonkey 	_GLOBAL__sub_I_TimeStamp.cpp 	/builds/slave/c-cen-t-lnx64/build/mozilla/mozglue/misc/TimeStamp.cpp:47
37 		@0x7fff86e2b4ef 	
38 	seamonkey 	__libc_csu_fini 	
39 	seamonkey 	_GLOBAL__sub_I_TimeStamp.cpp 	/builds/slave/c-cen-t-lnx64/build/mozilla/mozglue/misc/TimeStamp.cpp:47
40 		@0x7fff86e2b4ef 	
41 	seamonkey 	_start
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1363036
You need to log in before you can comment on or make changes to this bug.