Printing Event Invitation incomplete

RESOLVED FIXED in 5.4.2

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: linux, Assigned: MakeMyDay)

Tracking

({regression})

Lightning 5.4
5.4.2
regression

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.114 Safari/537.36 Vivaldi/1.9.818.50

Steps to reproduce:

Installing 52.1.1 on different machines -> same result
Installing previous version -> expected result


Actual results:

When you try to print an event invitation, the event is missing, even in the print preview.
Only the header (from, to, subject et.) is shown.



Expected results:

The header and the event are shown and you can find it on the print.

Comment 1

2 years ago
I can confirm that when printing a message that contains an event, the event doesn't show up in print preview.
Status: UNCONFIRMED → NEW
Component: Message Reader UI → General
Ever confirmed: true
Product: Thunderbird → Calendar
Version: 52 Branch → Lightning 5.4

Updated

2 years ago
Component: General → Printing
Any error console messages? Can you attach a screenshot?
Flags: needinfo?(linux)

Comment 3

2 years ago
Created attachment 8869796 [details]
Screenshot showing event in message pane and print preview

No error in the console. I think this is a problem of how the ICS attachment is rendered for printing, as a wild guess, maybe some MIME call not being set up correctly. I've just come across this recently:
https://dxr.mozilla.org/comm-central/rev/9285e79dfd098b4d5e6de6c12550e72c98387ce4/mailnews/mime/src/mimei.cpp#463
Maybe not triggered for printing. Anyway, I could be 500% wrong ;-(
Flags: needinfo?(linux)
(Assignee)

Comment 4

2 years ago
We had an issue with that in 4.7.*, but this was successfully fixed with bug 1268856, so this has been working again with 4.7.2++ and must be a regression. Have there been any mime handling changed for TB52 in mailnews?
Keywords: regression, regressionwindow-wanted

Comment 5

2 years ago
(In reply to [:MakeMyDay] from comment #4)
> Have there been any mime handling changes for TB52 in mailnews?
Yes, plenty:
https://hg.mozilla.org/comm-central/log/tip/mailnews/mime/src/mimemalt.cpp
https://hg.mozilla.org/comm-central/log/tip/mailnews/mime/src/mimei.cpp
https://hg.mozilla.org/comm-central/log/tip/mailnews/mime/src/mimeleaf.cpp

I'm sure Alice can find the regression for us. Alice, please print preview the attached message (from bug 1360155, slightly edited).
Flags: needinfo?(alice0775)

Comment 6

2 years ago
Created attachment 8869824 [details]
Event test 3.eml

Comment 8

2 years ago
Thanks Alice. Very much appreciated, as always.

Looks like MIME and me didn't break it, but you calendar guys did ;-)
(Assignee)

Comment 9

2 years ago
Created attachment 8869846 [details] [diff] [review]
FixInvitationPrinting-v1.diff

Thanks for detectiong the regression range. Yes, my bad. With bug 1225784, I accidentally partly reverted the fix from bug 1268856.

This patch takes care of it.
Assignee: nobody → makemyday
Status: NEW → ASSIGNED
Attachment #8869846 - Flags: review?(philipp)
(Assignee)

Updated

2 years ago
Blocks: 1225784
Keywords: regressionwindow-wanted
Attachment #8869846 - Flags: review?(philipp) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
(Assignee)

Updated

2 years ago
Attachment #8869846 - Flags: approval-calendar-esr?(philipp)
Attachment #8869846 - Flags: approval-calendar-beta?(philipp)

Comment 10

2 years ago
https://hg.mozilla.org/comm-central/rev/28736b5614d4bb06cb13b386fa4d3cc1e8467418
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 5.7

Comment 11

2 years ago
Works nicely now, thanks for fixing it quickly!
Attachment #8869846 - Flags: approval-calendar-esr?(philipp)
Attachment #8869846 - Flags: approval-calendar-esr+
Attachment #8869846 - Flags: approval-calendar-beta?(philipp)
Attachment #8869846 - Flags: approval-calendar-beta+

Comment 12

2 years ago
Beta (TB 54, Calendar 5.6):
https://hg.mozilla.org/releases/comm-beta/rev/02ee438e62f57d9dcaa8e93a10e3e43f8cc5e098
Target Milestone: 5.7 → 5.6
You need to log in before you can comment on or make changes to this bug.