hang when left-square-bracket is in URL bar

VERIFIED DUPLICATE of bug 134793

Status

SeaMonkey
Location Bar
--
critical
VERIFIED DUPLICATE of bug 134793
16 years ago
9 years ago

People

(Reporter: Andrew Haninger, Assigned: Joe Hewitt (gone))

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If you enter a left-square bracket in the URL bar and press [ENTER], it locks
Mozilla and it must be killed. I've tried this on Linux with the latest nightly
on 04/09/02 and Windows 2000 with 0.9.9.

Comment 1

16 years ago
Confirming, Linux 2002040814(RH7.2 RPMs) and marking NEW(unable to find dupe). 
This locked not only Mozilla but X too.  
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Just found bug 120103, this bug is a dupe of that one(though it was resolved
WORKSFORME).  

Updated

16 years ago
Severity: major → critical
Keywords: crash

Comment 3

16 years ago
Hangs on Win2k 2002040903

crash -> hang
OS -> all

Stack trace I get breaking in is

XPCOM! 6111f222()
XPCOM! 6111fdc1()
NECKO! 60960a98()
NECKO! 60960040()
NECKO! 60961736()
XPCOM! 611169b8()
XPC3250! 60d0239c()
XPC3250! 60d0591b()
JS3250! 60dda415()
JS3250! 60ddf4b0()
JS3250! 60dda452()
JS3250! 60dd7f87()
JS3250! 60dda415()
JS3250! 60ddf4b0()
JS3250! 60dda452()
JS3250! 60dda6ec()
JS3250! 60dc4919()
JSDOM! 606d3c28()
JSDOM! 606ed877()
GKCONTENT! 01a7cbc3()
GKCONTENT! 01a7f4ee()
GKCONTENT! 01a7f539()
GKCONTENT! 01a4c7bf()
GKCONTENT! 01a4c719()
GKCONTENT! 01a4c719()
GKCONTENT! 019c82e1()
GKCONTENT! 01aae51a()
GKLAYOUT! 603d60e7()
GKLAYOUT! 603d5f97()
GKVIEW! 60537808()
GKVIEW! 6053130d()
GKVIEW! 60531b4b()
GKWIDGET! 605444d2()
GKWIDGET! 60545d21()
GKWIDGET! 60545f51()
GKWIDGET! 60546870()
GKWIDGET! 605449f0()
USER32! 77e11b60()
USER32! 77e11cca()
USER32! 77e183f1()
APPSHELL! 600d6bd7()
MOZILLA! 00401aed()
MOZILLA! 0040365b()
KERNEL32! 77e8d326()
(Reporter)

Comment 4

16 years ago
Bug 120103 referred to `[' being anywhere in the URL. Mozilla still crashes if
just [ is in the URL bar.

X does not lock up, only Mozilla does. If I switch to a text VT and killall
mozilla-bin, mozilla is killed and I can restart it just fine.

Comment 5

16 years ago
Also crashes on 0.9.9 (build 2002031104) under Windows 98 SE. Changing OS 
to 'all'. 
OS: Linux → All
Keywords: crash → hang
Summary: crash when left-square-bracket is in URL bar → hang when left-square-bracket is in URL bar

Comment 6

16 years ago
this is a dupe of 134793

*** This bug has been marked as a duplicate of 134793 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.