Closed Bug 1366162 Opened 2 years ago Closed 2 years ago

stylo: support -moz-context-properties

Categories

(Core :: CSS Parsing and Computation, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1367275

People

(Reporter: TYLin, Unassigned)

References

()

Details

Running "RUST_LOG=debug ./mach run" outputs:

19:3 Unsupported property declaration: '-moz-context-properties: fill;'

Also, -moz-context-properties is needed by video controls [1].

[1] http://searchfox.org/mozilla-central/rev/24c443a440104dabd9447608bd41b8766e8fc2f5/toolkit/themes/shared/media/videocontrols.css#100
Blocks: 1366163
CJ, is this bug dup of bug 1338764? If yes, we'll need to fix bug 1338764 for <video controls> to work in stylo.
Flags: needinfo?(cku)
No, I don't this so. 
Unsupported property declaration: '-moz-context-properties: fill;'
This message said something wrong about _declaration_; bug 1338764 is a bug relative to property value.
Flags: needinfo?(cku)
Flags: needinfo?(aschen)
Flags: needinfo?(aschen)
Manish, was this one of the 10 remaining properties you were going to knock out?
Flags: needinfo?(manishearth)
Priority: -- → P2
Turns out I'd missed this one when grepping the css properties file due to a comment.

also missed -moz-min-font-size-ratio. Will do both in bug 1367275
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(manishearth)
Resolution: --- → DUPLICATE
Duplicate of bug: 1367275
You need to log in before you can comment on or make changes to this bug.