Closed Bug 1366426 Opened 3 years ago Closed 3 years ago

autocomplete-richlistbox height does not fit results

Categories

(Firefox :: Address Bar, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- verified

People

(Reporter: magicp.jp, Assigned: mak)

References

Details

(Keywords: regression, Whiteboard: [fxsearch])

Attachments

(2 files)

[Steps to reproduce]
1. Start latest Nightly (e.g. Build ID: 20170519030205)
2. Enter any words in urlbar > autocomplete-richlistbox will be displayed
3. Disable search suggestions question, If it is displayed

[Actual Results]
Vertical scrollbar is appeared, because autocomplete-richlistbox height does not fit results.

[Expected Results]
autocomplete-richlistbox height should be fit results.

[Regression Range]
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=dd7f4e79194b18321576e48f2dd932a105b7eec4&tochange=c27dda89b4eb396f641885fa0beaf93ad61eaa70
Version: unspecified → Trunk
Blocks: 1344924
Could be due to the removal of a layout flush. fwiw apart from checking how hard this is to fix, we should add overflow:hidden since we never want a scrollbar
Component: Theme → Location Bar
Priority: -- → P1
Whiteboard: [fxsearch]
Keywords: regression
Duplicate of this bug: 1366516
Investigating...
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Blocks: 1365958
Comment on attachment 8871335 [details]
Bug 1366426 - autocomplete-richlistbox height does not fit results anymore.

https://reviewboard.mozilla.org/r/142812/#review147060
Attachment #8871335 - Flags: review?(adw) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/75f640c290e2
autocomplete-richlistbox height does not fit results anymore. r=adw
https://hg.mozilla.org/mozilla-central/rev/75f640c290e2
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Duplicate of this bug: 1365958
I have reproduced this bug with Nightly 55.0a1 (2017-05-19) (64-bit) on Ubuntu 16.04 LTS!

This bug's fix is verified with latest Nightly!

Build ID   : 20170605100313
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
QA Whiteboard: [bugday-20170607]
I have reproduced this bug with Nightly 55.0a1 (2017-05-19) on Windows 10 (64-bit)

This bug's fix is verified with latest Nightly!

Build ID   :  20170605030204
User Agent : Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170607]
As per comment 9 and comment 10, I am marking this bug as Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.