Socorro should sort comments by default by date submitted

VERIFIED FIXED

Status

Socorro
Webapp
VERIFIED FIXED
9 months ago
6 months ago

People

(Reporter: BesTo, Assigned: peterbe)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
Socorro should sort comments by default by date submitted.

To reproduce:
- Go e.g. to: https://crash-stats.mozilla.com/signature/?signature=EMPTY%3A%20no%20crashing%20thread%20identified%3B%20ERROR_NO_MINIDUMP_HEADER#comments
- Look at the sort order of the comments. No clue what's the logic behind the sort.
Mentor: adrian@mozilla.com

Comment 1

8 months ago
Hi,
Can somebody assign me this bug? I would like to work on this.

And a little help regarding how to start things would be great...
(Reporter)

Comment 2

8 months ago
You can get the code at: https://github.com/mozilla/socorro
Assignee: nobody → cooldipanks14
(Reporter)

Updated

8 months ago
Status: NEW → ASSIGNED

Comment 3

8 months ago
Having a little problem setting up socorro. Can somebody help?

I am using ubuntu 16.04. Installed vagrant and followed steps as mentioned in the docs till "vagrant up". When I did this for the first time a box was downloaded cent-OS-7.0.64 puppet. After this lot of changes took place while a few of them encountered errors.

Pasting the error-
..............................................................................................................................==> default: Error: Could not update: Execution of '/bin/yum -d 0 -e 0 -y install gcc-c++' returned 1: One of the configured repositories failed (Extra Packages for Enterprise Linux 7 - x86_64),
==> default:  and yum doesn't have enough cached data to continue. At this point the only
==> default:  safe thing yum can do is fail. There are a few ways to work "fix" this:
==> default: 
==> default:      1. Contact the upstream for the repository and get them to fix the problem.
==> default: 
==> default:      2. Reconfigure the baseurl/etc. for the repository, to point to a working
==> default:         upstream. This is most often useful if you are using a newer
==> default:         distribution release than is supported by the repository (and the
==> default:         packages for the previous distribution release still work).
==> default: 
==> default:      3. Disable the repository, so yum won't use it by default. Yum will then
==> default:         just ignore the repository until you permanently enable it again or use
==> default:         --enablerepo for temporary usage:
==> default: 
==> default:             yum-config-manager --disable epel
==> default: 
==> default:      4. Configure the failing repository to be skipped, if it is unavailable.
==> default:         Note that yum will try to contact the repo. when it runs most commands,
==> default:         so will have to try and fail each time (and thus. yum will be be much
==> default:         slower). If it is a very temporary problem though, this is often a nice
==> default:         compromise:
==> default: 
==> default:             yum-config-manager --save --setopt=epel.skip_if_unavailable=true
==> default: 
==> default: failure: repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz from epel: [Errno 256] No more mirrors to try.
==> default: https://mirrors.ustc.edu.cn/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
==> default: https://mirrors.tuna.tsinghua.edu.cn/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
==> default: http://kartolo.sby.datautama.net.id/EPEL/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://ftp.jaist.ac.jp/pub/Linux/Fedora/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://ftp.cuhk.edu.hk/pub/linux/fedora-epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://mirror01.idc.hinet.net/EPEL/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: https://mirror.pregi.net/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
==> default: https://epel.mirror.angkasa.id/pub/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
==> default: https://ftp.yz.yamagata-u.ac.jp/pub/linux/fedora-projects/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
==> default: http://ae.mirror.rasanegar.com/fedoraproject/pub/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://mirror.premi.st/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://mirror.vinahost.vn/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://epel.scopesky.iq/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://mirror.rise.ph/fedora-epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: Error: /Stage[main]/Socorro::Vagrant/Package[gcc-c++]/ensure: change from purged to latest failed: Could not update: Execution of '/bin/yum -d 0 -e 0 -y install gcc-c++' returned 1: One of the configured repositories failed (Extra Packages for Enterprise Linux 7 - x86_64),
==> default:  and yum doesn't have enough cached data to continue. At this point the only
==> default:  safe thing yum can do is fail. There are a few ways to work "fix" this:
==> default: 
==> default:      1. Contact the upstream for the repository and get them to fix the problem.
==> default: 
==> default:      2. Reconfigure the baseurl/etc. for the repository, to point to a working
==> default:         upstream. This is most often useful if you are using a newer
==> default:         distribution release than is supported by the repository (and the
==> default:         packages for the previous distribution release still work).
==> default: 
==> default:      3. Disable the repository, so yum won't use it by default. Yum will then
==> default:         just ignore the repository until you permanently enable it again or use
==> default:         --enablerepo for temporary usage:
==> default: 
==> default:             yum-config-manager --disable epel
==> default: 
==> default:      4. Configure the failing repository to be skipped, if it is unavailable.
==> default:         Note that yum will try to contact the repo. when it runs most commands,
==> default:         so will have to try and fail each time (and thus. yum will be be much
==> default:         slower). If it is a very temporary problem though, this is often a nice
==> default:         compromise:
==> default: 
==> default:             yum-config-manager --save --setopt=epel.skip_if_unavailable=true
==> default: 
==> default: failure: repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz from epel: [Errno 256] No more mirrors to try.
==> default: https://mirrors.ustc.edu.cn/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
==> default: https://mirrors.tuna.tsinghua.edu.cn/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
==> default: http://kartolo.sby.datautama.net.id/EPEL/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://ftp.jaist.ac.jp/pub/Linux/Fedora/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://ftp.cuhk.edu.hk/pub/linux/fedora-epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://mirror01.idc.hinet.net/EPEL/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: https://mirror.pregi.net/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
==> default: https://epel.mirror.angkasa.id/pub/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
==> default: https://ftp.yz.yamagata-u.ac.jp/pub/linux/fedora-projects/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTPS Error 404 - Not Found
==> default: http://ae.mirror.rasanegar.com/fedoraproject/pub/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://mirror.premi.st/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://mirror.vinahost.vn/epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://epel.scopesky.iq/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
==> default: http://mirror.rise.ph/fedora-epel/7/x86_64/repodata/742c7a4cd87f9bf9ce75f772a0c49fe4e9ea26e06d8779a586e2f15e0ba0b71a-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found
.............................................................................................................................
"vagrant up" after that is working as expected. Output of "vagrant up" is-

Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'puppetlabs/centos-7.0-64-puppet' is up to date...
==> default: Machine already provisioned. Run `vagrant provision` or use the `--provision`
==> default: flag to force provisioning. Provisioners marked to run always will still run.
.............................................................................................................................

Output ofm"vagrant ssh"

Welcome to the Socorro vagrant environment!

Documentation for using this environment can be found at:

https://socorro.readthedocs.io/

Dev docs are at:

https://socorro.readthedocs.io/en/latest/development/

If you need help, we're on #breakpad on irc.mozilla.org
.............................................................................................................................
 
But I am unable to open "http://crash-stats".
Flags: needinfo?(adrian)
(Reporter)

Comment 6

8 months ago
Dipankar, do you know Socorro?

You can "play" a little bit with it here:
https://crash-stats.mozilla.com/home/product/Firefox

And if you enter about:crashes in the URL-Bar of Fx, you get a list with your crashes...
...and can open from there the crashes in crash-stats.mozilla.com...

Comment 7

8 months ago
Vagrant is no longer a supported dev environment. See bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1375255

An "intent to switch to docker" email went out to the mailing list and there's broad agreement but we haven't made time to actually remove the old documentation yet.
Peter and I landed a docs overhaul last week, but readthedocs didn't build it. Looks like it didn't update things when we switched git orgs.

I fixed that just now and we should have docker-environment based development docs in like 10 minutes.

Comment 9

8 months ago
Thanks a lot. That will help setting up the environment.
Sadly I don't have time to mentor this anymore.
Mentor: adrian@mozilla.com
Flags: needinfo?(adrian)
(Assignee)

Updated

7 months ago
Assignee: cooldipanks14 → nobody
Status: ASSIGNED → NEW
(Assignee)

Comment 11

7 months ago
PR https://github.com/mozilla-services/socorro/pull/3881
Assignee: nobody → peterbe

Comment 12

6 months ago
Commit pushed to master at https://github.com/mozilla-services/socorro

https://github.com/mozilla-services/socorro/commit/6d89e3e5fc5029b29a949fe6355c243cf9f34ab8
fixes bug 1366482 - sort signature comments by default by date (#3881)

* fixes bug 1366482 - sort signature comments by default by date

* diable jquery tablesorter on the comments tab

Updated

6 months ago
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
(Reporter)

Comment 13

6 months ago
Not yet on https://crash-stats.mozilla.com, right?
(Assignee)

Comment 14

6 months ago
(In reply to Tobias B. Besemer [:BesTo] (QA) from comment #13)
> Not yet on https://crash-stats.mozilla.com, right?

Sometime later next week.
(Assignee)

Comment 15

6 months ago
Works as expected in stage.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.