Closed Bug 1366498 Opened 5 years ago Closed 5 years ago

Do not fail the build on -Werror=format-overflow for webrtc

Categories

(Core :: WebRTC, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: Sylvestre, Assigned: Sylvestre)

References

Details

Attachments

(1 file)

Breaks the build with gcc 7.1 and --enable-warnings-as-errors
Summary: Disable format-overflow for webrtc → Don't not fail the build on -Werror=format-overflow for webrtc
Summary: Don't not fail the build on -Werror=format-overflow for webrtc → Do not fail the build on -Werror=format-overflow for webrtc
Assignee: nobody → sledru
It seems like it would be better to fix these warnings. Can you post the compiler warnings so we can evaluate them?
(In reply to Eric Rescorla (:ekr) from comment #2)
> It seems like it would be better to fix these warnings. Can you post the
> compiler warnings so we can evaluate them?

We'd want to fix the errors for media/webrtc/signaling (that's basically all our code).  media/webrtc/trunk we probably should disable the warning (for now); we could try enabling it again and fixing the bugs (in the upstream repo preferably) after the v57 import (about to land next week) or the import after that.

Nils, who do you think would be a good choice to work on this?
Flags: needinfo?(drno)
Comment on attachment 8869737 [details]
Bug 1366498 - Don't fail the build on -Werror=format-overflow for webrtc

https://reviewboard.mozilla.org/r/141310/#review144894
Attachment #8869737 - Flags: review?(rjesup)
Can't reproduce it anymore. Maybe a false positive from gcc as I use a snapshot version. Sorry for the noise :(
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
I started bug 1369926 for the warnings in nrappkit. nICEr has even more warnings, but I haven't filed a bug for that.
Flags: needinfo?(drno)
See Also: → 1369926
You need to log in before you can comment on or make changes to this bug.