Thunderbird Menu: right arrow indicating a sub menu is missing

UNCONFIRMED
Unassigned

Status

()

P2
normal
UNCONFIRMED
2 years ago
29 days ago

People

(Reporter: chriechers, Unassigned)

Tracking

({polish})

60 Branch
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:+)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8869841 [details]
missing_menu_arrow.png

User Agent: Mozilla/5.0 (X11; Linux i686; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170518175637

Steps to reproduce:

Click Thunderbird Menu button.


Actual results:

The right arrow indicating a sub menu is missing. See attached screenshot.
Thunderbird 54.0b1, Linux OpenSUSE 13.2, Gnome 3.14.2, GTK+ 3.14.15
This started with TB52.
(Reporter)

Comment 1

2 years ago
Also happens in safe mode.
This is the vanilla Thunderbird version from Mozilla.
(Reporter)

Comment 2

2 years ago
FF54 beta has the same problem with menu bar items.
There was bug 1276534 for FF50. The status of that bug is RESOLVED FIXED, but the problem still exists.
I think, this is again a problem with too old GTK3 version. As FX has the same issue -> Widget: GTK
Component: Untriaged → Widget: Gtk
Product: Thunderbird → Core
(Reporter)

Comment 4

2 years ago
Both, FF and TB 54 beta release notes specify as system requirements:
GTK+ 3.4 or higher
I'm on GTK+ 3.14.
Duplicate of this bug: 1367200

Updated

2 years ago
Keywords: polish
Priority: -- → P2
Whiteboard: tpi:+
(Reporter)

Comment 6

2 years ago
Updated to Gnome 3.24, GTK 3.22, and there are no more problems.

Comment 7

2 years ago
Thanks for letting us know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
This bug still exists. Updating GTK+ is not a solution, because older GTK+ releases are still used out there, usually in LTS distributions, and Firefox supports those.

I have done some investigation here and found that newer Firefox releases don't have this bug, they show the arrow icons on the History sidebar just fine. However 60.0 ESR versions have this bug. Doing a bisect (with mozilla.org builds) I found that the problem was still present in 62.x, but got fixed in 63.0b3. Bisecting nightly releases between those, I found that

https://archive.mozilla.org/pub/firefox/nightly/2018/06/2018-06-29-22-01-05-mozilla-central/

is the first one that works. Looking at mozilla-central around that time, the most likely candidate is:

https://hg.mozilla.org/mozilla-central/rev/93972d67be61

I'm not sure if that's a valid candidate for a backport to 60 ESR though. I still haven't investigated the origin of this error, i.e. why it's passing a scale <= 1 and why that's working with newer GTK+:

(firefox:2309): Gtk-CRITICAL **: gtk_icon_theme_lookup_icon_for_scale: assertion 'scale >= 1' failed

(Same for thunderbird)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Version: 54 Branch → 60 Branch
You need to log in before you can comment on or make changes to this bug.