YouTube video title not correctly displayed in History or Top Tabs

VERIFIED FIXED

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: SimonB, Assigned: justindarc)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios8.0+, fxios-v8.0 verified, fxios-v9.0 verified)

Details

(Whiteboard: [MobileCore])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Build: b3b12590bebb48
Device: iPad Air 2
iOS: 10.3.1

Steps to reproduce: 
1. Go to yoube.com
2. Play a video
3. Check the History list

Actual results:
- Home - Youtube will be displayed in the History list after visiting a video. The videos title will appear correct in the history list only after tapping the refresh button after step 2). 

Expected results:
- The video title should be correctly displayed in the History list.

Note:
- Issue not reproducible on Safari.
(Assignee)

Updated

2 years ago
Assignee: nobody → jdarcangelo
tracking-fxios: ? → 8.0+
Priority: -- → P1
(Assignee)

Updated

2 years ago
See Also: → bug 1360121
Whiteboard: [MobileCore]
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

2 years ago
The URL is correctly recorded in the History list, but the updated page title is not. The title does not correctly update in Top Tabs on iPad too.
Summary: Youtube video title will not be correctly displayed in History list → YouTube video title not correctly displayed in History or Top Tabs
(Assignee)

Comment 2

2 years ago
Created attachment 8870555 [details] [review]
GitHub Pull Request

Something must have changed with YouTube between the time we landed the last History patch and now because I know for sure that this was working. Regardless, it seems as though it is also necessary to observe changes to `webView.title` in the event that the `document.title` is not set at the same time that history state is pushed by the web content. So, even though this *was* working for YouTube last week, its likely that it was not working with all single-page web apps.

I also took a peek at Chromium for iOS and it looks as though they are also observing `webView.title`. You'll also notice that I put some extra checks in the observer to work around cases where the `webView` repeatedly fires changes to `title`.

When time permits, we really need to look into consolidating all of these WKWebView state changes in one place.
Attachment #8870555 - Flags: review?(fpatel)
(Assignee)

Updated

2 years ago
Iteration: --- → 1.22
(Assignee)

Comment 3

2 years ago
Comment on attachment 8870555 [details] [review]
GitHub Pull Request

Carrying over :farhan's R+ from GitHub PR.
Attachment #8870555 - Flags: review?(fpatel) → review+
(Reporter)

Comment 5

2 years ago
Verifying as fix on master 4538e6d3 and 8.0b3672. The youtube videos are correctly displayed in the History list.
Status: RESOLVED → VERIFIED
status-fxios-v8.0: affected → verified
status-fxios-v9.0: --- → verified
You need to log in before you can comment on or make changes to this bug.