Closed Bug 1366729 Opened 2 years ago Closed 2 years ago

Android Nightlys broken since may 19th

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

defect
Not set

Tracking

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55blocking fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 blocking fixed

People

(Reporter: cbook, Assigned: glandium)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

Seems the Android Trunk nightlys are broken somehow since sunday with https://treeherder.mozilla.org/logviewer.html#?job_id=100871919&repo=mozilla-central&lineNumber=56590

[task 2017-05-22T10:48:14.955679Z] 10:48:14     INFO -  10:48:14     INFO -  /home/worker/workspace/build/src/toolkit/mozapps/installer/packager.mk:39: recipe for target 'stage-package' failed

Catlee: do you know who could take a look ?
Flags: needinfo?(catlee)
Maybe bug 1366169? That introduced an error message that shows up in the log often. That landed on the 19th, though.
Flags: needinfo?(mh+mozilla)
Flags: needinfo?(gps)
Duplicate of this bug: 1366743
:pascalc also filed a bug on this under bug 1366743. Looks like nightlies were broken ever since 19th since thats when we last got artifacts under https://archive.mozilla.org/pub/mobile/nightly/latest-mozilla-central-android-api-15/.
I don't get how my bug is a dupe of this if it is then please explain why did I not get a 5/20 update????
(In reply to Axel Hecht [:Pike] from comment #1)
> Maybe bug 1366169? That introduced an error message that shows up in the log
> often. That landed on the 19th, though.

Like I said no nightly updated from 5/19 builds so no idea why this bug says issue started
 on 5/21.
I also find it just funny that things glandium is fond of calling footguns, his fixes for end up being a footgun.  Just sayin! ;-)
At first glance, I suspect :Pike's right. We do get lots of "[task 2017-05-22T10:48:12.861816Z] 10:48:12     INFO -  10:48:12     INFO -  Error: /home/worker/workspace/build/src/obj-firefox/dist/bin/chrome/en-US.manifest:1: "locale alerts en-US en-US/locale/en-US/alerts/" overrides "locale alerts en-US en-US/locale/en-US/alerts/"" which seem pretty much related to https://hg.mozilla.org/mozilla-central/rev/1100dbb56818#l2.63
Summary: Android Nightlys broken since may 21 → Android Nightlys broken since may 19th
(In reply to Bill Gianopoulos [:WG9s] from comment #4)
> I don't get how my bug is a dupe of this if it is then please explain why
> did I not get a 5/20 update????

Hey Bill,

Which bug are you talking about? If you're talking about bug 1366743, my reasoning to close that as a dupe was purely chronological (this bug was filed before that by ~2h) + the fact that lots of people were already roped in here. Not sure if this is best practice or not but I usually consider for refence the ones that arrive first in a chronological order. I could be wrong, it's just a matter of my own preference. Fwiw, I have also amended the title to reflect the since-5/19 brokage reality.
(In reply to Mihai Tabara [:mtabara]⌚️GMT from comment #8)
> (In reply to Bill Gianopoulos [:WG9s] from comment #4)
> > I don't get how my bug is a dupe of this if it is then please explain why
> > did I not get a 5/20 update????
> 
> Hey Bill,
> 
> Which bug are you talking about? If you're talking about bug 1366743, my
> reasoning to close that as a dupe was purely chronological (this bug was
> filed before that by ~2h) + the fact that lots of people were already roped
> in here. Not sure if this is best practice or not but I usually consider for
> refence the ones that arrive first in a chronological order. I could be
> wrong, it's just a matter of my own preference. Fwiw, I have also amended
> the title to reflect the since-5/19 brokage reality.

NO now that the the title is amended I have no issue on it being duped.  Was A bug about and issue that started on 5/19 being duped to a bug saying it started 2 days later that was the issue.  I thought perhaps these were NOT the same issue because of the different start dates.
This is fallout from changes that were tracked in bug 1366169. The packaging code now detects some scenarios that could lead to files being overwritten when you probably didn't intend for them to be. The fix is either to loosen the overwriting restrictions or to restructure the packaging manifests so they don't trigger the overrides. Preferably the latter.

With only looking at the error message, it looks like there are redundant entries for "locale alerts en-US en-US/locale/en-US/alerts/". You'll want to either remove one or restrict one to a tighter scope so it isn't exactly redundant.

I'll needinfo glandium just in case. But I think this can be fixed with a trivial change to packaging manifests.
Depends on: 1366169
Flags: needinfo?(gps)
Actually, this might be two problems:

One is that with multi-locale packaging, we add en-US a second time to the temporary manifest, so it feels like we're packaging something as en-US we already have. Not too bad, if it was the same?

The other is, we're packaging locales over and over, and they're actually complaining about one locale overwriting the other. That sounds like a bug in the check, which should distinguish overrides in zh-TW from those on en-US or kk.

Clearing needinfo on catlee, as this is a build issue.

Tentatively moving it to Firefox Android, but I also think that there are aspects here that are Core Build.
Component: General → Build Config & IDE Support
Flags: needinfo?(catlee)
Keywords: regression
Product: Release Engineering → Firefox for Android
Version: unspecified → Trunk
Do we need to backout 1366169 to get nightlies back?
Flags: needinfo?(mh+mozilla)
Comment on attachment 8870193 [details]
Bug 1366729 - Properly handle "multi-content" manifest entries after bug 1366169.

https://reviewboard.mozilla.org/r/141638/#review145596
Attachment #8870193 - Flags: review?(gps) → review+
Comment on attachment 8870194 [details]
Bug 1366729 - Skip manifest entries that are packaged twice.

https://reviewboard.mozilla.org/r/141640/#review145598
Attachment #8870194 - Flags: review?(gps) → review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aec720895e5e
Properly handle "multi-content" manifest entries after bug 1366169. r=gps
https://hg.mozilla.org/integration/autoland/rev/249495cc2ea5
Skip manifest entries that are packaged twice. r=gps
https://hg.mozilla.org/mozilla-central/rev/aec720895e5e
https://hg.mozilla.org/mozilla-central/rev/249495cc2ea5
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Assignee: nobody → mh+mozilla
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 55 → mozilla55
You need to log in before you can comment on or make changes to this bug.