Closed Bug 1366738 Opened 3 years ago Closed 1 year ago

Implement [LegacyWindowAlias] extended attribute (for WebKitCSSMatrix, webkitURL)

Categories

(Core :: DOM: Bindings (WebIDL), enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: zcorpan, Assigned: saschanaz, NeedInfo)

References

Details

(Keywords: dev-doc-needed)

Attachments

(1 file)

Blocks: 1366734
Should we do this?
Flags: needinfo?(annevk)
Flags: needinfo?(amarchesini)
Yes, we should but it requires an important change in the WebIDL codegen.
A temporary solution would be use NamedConstructor as discussed here: https://github.com/heycam/webidl/issues/362#issuecomment-302044931
Flags: needinfo?(amarchesini)
Andrea and I discussed this and it doesn't seem important to tackle this before Firefox 57, especially as bz said it would be non-trivial.
Flags: needinfo?(annevk)
Priority: -- → P3
Component: DOM → DOM: Core & HTML
Component: DOM: Core & HTML → DOM: Bindings (WebIDL)
Assignee: nobody → saschanaz

Add [LegacyWindowAlias] extended attribute support for WebKitCSSMatrix and webkitURL.

Depends on: 1397945
Depends on: 1560480
Keywords: checkin-needed

Pushed by aiakab@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/509af1e0771d
Implement [LegacyWindowAlias] r=bzbarsky

Keywords: checkin-needed

Backed out changeset 509af1e0771d for causing failures in test_WebKitCSSMatrix.html

Backout link: https://hg.mozilla.org/integration/autoland/rev/a70f62521b875857e709f4120006ac2429c869c2

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&fromchange=509af1e0771d619a0b6d73bffec0583f4f0db9a9&tochange=a70f62521b875857e709f4120006ac2429c869c2&searchStr=mochitest&selectedJob=254553208

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=254553208&repo=autoland&lineNumber=32339

[task 2019-07-03T07:10:30.318Z] 07:10:30 INFO - TEST-UNEXPECTED-FAIL | dom/tests/mochitest/general/test_WebKitCSSMatrix.html | Test that inverting an invertible matrix throws. - Test that inverting an invertible matrix throws.: assert_throws: Inverting an invertible matrix should throw. function "function() { m.inverse(); }" did not throw
[task 2019-07-03T07:10:30.318Z] 07:10:30 INFO - TEST-PASS | dom/tests/mochitest/general/test_WebKitCSSMatrix.html | Test for WebKitCSSMatrix - Test for WebKitCSSMatrix: Elided 4 passes or known failures.

Flags: needinfo?(saschanaz)
Flags: needinfo?(saschanaz)
Keywords: checkin-needed

Pushed by aiakab@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a618b9ef5080
Implement [LegacyWindowAlias] r=bzbarsky

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

After review, I do not believe anything here reaches the level of needing to be documented on MDN. If anyone can think of a reason that wouldn't be true, let me know.

Keywords: dev-doc-needed

https://developer.mozilla.org/en-US/docs/Web/API/CSSMatrix

I think this should redirect to https://developer.mozilla.org/en-US/docs/Web/API/DOMMatrix and this should say that SVGMatrix and WebKitCSSMatrix are legacy aliases to DOMMatrix in a Window context. (Though SVGMatrix is not yet implemented as an alias.) Recommend using DOMMatrix instead of WebKitCSSMatrix.

https://developer.mozilla.org/en-US/docs/Web/API/URL could say that webkitURL exists as a legacy alias in a Window context. Recommend using URL instead.

Flags: needinfo?(eshepherd)
Duplicate of this bug: 1366734

Adding back dev-doc-needed for my above comment

Keywords: dev-doc-needed
You need to log in before you can comment on or make changes to this bug.