Change stub installer icon

VERIFIED FIXED in Firefox 55

Status

()

Firefox
Installer
VERIFIED FIXED
11 months ago
9 months ago

People

(Reporter: RT, Assigned: mhowell)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 verified)

Details

User Story

The streamlined stub installer icon is the same as the Firefox executable icon, this may cause user confusion with users re-installing Firefox to launch it.

As a user installing Firefox, I want to visually understand the difference between the stub installer icon and the Firefox icon so that I don't get confused.

Acceptance criteria:
- Update stub installer icon to a new icon that does not look like the Firefox icon
- Do not change the UAC prompt icon (the UAC prompt icon brings trust at a moment where users have to trust that they install a legitimate copy of Firefox)

Attachments

(5 attachments, 3 obsolete attachments)

Comment hidden (empty)
(Reporter)

Updated

11 months ago
User Story: (updated)
(Reporter)

Comment 1

11 months ago
Sean, per our discussion please provide the asset here for the icon so that Matt can follow-up with implementation.
Flags: needinfo?(smartell)
(Reporter)

Updated

11 months ago
Blocks: 1328445

Updated

11 months ago
Blocks: 1367070

Updated

11 months ago
Assignee: nobody → smartell

Comment 2

11 months ago
Any update on this?
Are we still on track to land this today?
Flags: needinfo?(rtestard)
(Reporter)

Comment 3

11 months ago
Icon from Sean:
https://people-mozilla.org/~smartell/photon/firefox_installer.png
Matt and Grover, are we OK to make the change at this stage without risking the QA sign-off date?
Flags: needinfo?(rtestard)
Flags: needinfo?(mhowell)
Flags: needinfo?(gwimberly)
(Assignee)

Comment 4

11 months ago
Created attachment 8871785 [details]
New icon - original image

I'm attaching the image here since people.m.o is being shut down soon.

I can go ahead and patch this in today, it doesn't take long to do.
Flags: needinfo?(mhowell)
(Assignee)

Comment 5

11 months ago
Created attachment 8871794 [details]
New icon - converted to ICO

Here's my quick and dirty attempt at converting the PNG into the Windows ICO format, which really just involved shrinking it way down and adding transparency.

I'm a little worried about how the icon reads at the really small sizes. It looks great at 128x128 and at 64x64, and still really good at 32x32, but at 16x16, I think it loses too much detail to remain readable. And that size is what the Windows file explorer uses by default in the downloads folder on machines with standard DPI displays, so it does still need to look good. I wouldn't mind having an alternate version, just for those really small sizes. I also wouldn't mind if anyone wants to get a second opinion from, you know, an actual designer. ;)

Comment 6

11 months ago
(In reply to Matt Howell [:mhowell] from comment #5)
> Created attachment 8871794 [details]
> New icon - converted to ICO
> 
> Here's my quick and dirty attempt at converting the PNG into the Windows ICO
> format, which really just involved shrinking it way down and adding
> transparency.
> 
> I'm a little worried about how the icon reads at the really small sizes. It
> looks great at 128x128 and at 64x64, and still really good at 32x32, but at
> 16x16, I think it loses too much detail to remain readable. And that size is
> what the Windows file explorer uses by default in the downloads folder on
> machines with standard DPI displays, so it does still need to look good. I
> wouldn't mind having an alternate version, just for those really small
> sizes. I also wouldn't mind if anyone wants to get a second opinion from,
> you know, an actual designer. ;)

Hey Matt,
I see what you're saying. Michael is our UX designer. Michael can you please provide a second opinion for us?
Flags: needinfo?(mverdi)
(Assignee)

Comment 7

11 months ago
Created attachment 8871858 [details]
File explorer screenshot showing new icon

For the benefit of anybody not running Windows and/or not able to easily open .ico files, here's a screenshot of my file explorer window to show the new icon in context, along with the icon we're using on current nightlies (which is just the Firefox logo).
(In reply to Romain Testard [:RT] from comment #3)
> Icon from Sean:
> https://people-mozilla.org/~smartell/photon/firefox_installer.png
> Matt and Grover, are we OK to make the change at this stage without risking
> the QA sign-off date?

Yes, that's fine.
Flags: needinfo?(gwimberly)

Comment 9

11 months ago
(In reply to Nicole Yee (:nicoleyee) from comment #6)
> Hey Matt,
> I see what you're saying. Michael is our UX designer. Michael can you please
> provide a second opinion for us?

Yeah we need to fix that. Sean said he can do it next week.
Flags: needinfo?(mverdi)

Comment 10

11 months ago
Created attachment 8872730 [details]
icon64.png
Flags: needinfo?(smartell)

Comment 11

11 months ago
Created attachment 8872731 [details]
icon48.png

Comment 12

11 months ago
Created attachment 8872732 [details]
default32.png

Comment 13

11 months ago
Created attachment 8872733 [details]
default16.png

Comment 14

11 months ago
Bottom 4 sizes pixel refines and cleaned up.  Enjoy!

Updated

11 months ago
Target Milestone: --- → Firefox 55
(Assignee)

Comment 15

11 months ago
Created attachment 8872768 [details] [diff] [review]
Patch

Thanks, Sean, these look awesome!

Here's the patch. As Romain requested, this only replaces the file icon for the installers (both the stub and the full); the icon that appears in the UAC prompt and on the installer window will continue to be the Firefox/Dev Edition/Nightly application icon.
Assignee: smartell → mhowell
Attachment #8871785 - Attachment is obsolete: true
Attachment #8871794 - Attachment is obsolete: true
Attachment #8871858 - Attachment is obsolete: true
Attachment #8872768 - Flags: review?(robert.strong.bugs)
Comment on attachment 8872768 [details] [diff] [review]
Patch

rubberstamp since this is a binary patch
Attachment #8872768 - Flags: review?(robert.strong.bugs) → review+
Hi Matt, 

Is there a timeline that this build will be put into the Streamlined Stub Installer build that we're testing? Or will it be in Nightly the following day? Thanks!
Flags: needinfo?(mhowell)
(Assignee)

Comment 19

11 months ago
(In reply to Grover Wimberly IV [:Grover-QA] from comment #18)
> Hi Matt, 
> 
> Is there a timeline that this build will be put into the Streamlined Stub
> Installer build that we're testing? Or will it be in Nightly the following
> day? Thanks!

Should be in tomorrow's Nightly. If not, then definitely the one after that.
Flags: needinfo?(mhowell)

Comment 20

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/612e32792109
Status: NEW → RESOLVED
Last Resolved: 11 months ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Per Comment 19, I have downloaded the new Firefox Stub Installer on the Nightly main webpage, and it still contains the old icon. 

But per the link provided on Comment 20, it does contain the new stub installer icon, but not the installation procedure.

Matt, can you provide some clarification on this?
Flags: needinfo?(mhowell)
(Assignee)

Comment 22

11 months ago
I'm seeing the new icon on the file I get from https://www.mozilla.org/en-US/firefox/channel/desktop/#nightly.

This is going to sound really odd, but try moving the file to a different location and see if the new icon shows up then. I've noticed while working on this that the file explorer is being really aggressive about caching these icons, but changing the path the file is at gets around that.
Flags: needinfo?(mhowell)
Got it. Clearing the system cache for the administrator account solved the issue. Thanks for the assistance.
Status: RESOLVED → VERIFIED
status-firefox55: fixed → verified
(Assignee)

Updated

9 months ago
Duplicate of this bug: 513748
You need to log in before you can comment on or make changes to this bug.