Closed Bug 1366782 Opened 3 years ago Closed 3 years ago

Custom Tab: about:home launched when CustomTab activity is closed

Categories

(Firefox for Android :: General, defect)

55 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1362846
Tracking Status
firefox55 --- affected

People

(Reporter: sflorean, Unassigned)

References

(Blocks 1 open bug)

Details

Environment: 
Device: Huawei Honor (Android 5.1.1);
Build: Nightly 55.0a1 (2017-05-22);
Prerequisite: Fennec is closed, not in background.

Steps to reproduce:
1. Open a page using CustomTab; 
2. Tap on "x" from toolbar.

Expected result:
The Custom tab is closed and gmail app is displayed.

Actual result:
The Custom Tab is closed and about:home from Fennec is displayed.

Notes:
check the video: https://youtu.be/RI0NT5ZzzSM.
Can't reproduce, although it might be fixed by bug 1359531 (and bug 1356346 will turn everything upside down anyway).
Ah, got to correct myself: It's reproducible on Nightly, but only if we're not restoring tabs (either because the setting is turned off, or because there aren't any tabs to restore in the last session).
I can't reproduce it on a local build, so bug 1359531 will indeed fix this.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1362846
You need to log in before you can comment on or make changes to this bug.