Bug 1366854 (SQLite3.19.1)

Upgrade to SQLite 3.19.1

RESOLVED FIXED in Firefox 55

Status

()

enhancement
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: RyanVM)

Tracking

unspecified
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

()

Attachments

(1 attachment, 2 obsolete attachments)

2017-05-22 - Release 3.19.0

SQLite version 3.19.0 is a regularly scheduled maintenance release.

The emphasis on this release is improvements to the query planner. There are also some obscure bug fixes. There is no reason to upgrade unless you are having problems with a prior release.

Full changelog:
http://sqlite.org/releaselog/3_19_0.html
I suppose attaching the right patch would be a good idea...
Attachment #8870235 - Attachment is obsolete: true
Attachment #8870235 - Flags: review?(mak77)
Attachment #8870236 - Flags: review?(mak77)
Comment on attachment 8870236 [details] [diff] [review]
Upgrade SQLite to version 3.19.0

Review of attachment 8870236 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Attachment #8870236 - Flags: review?(mak77) → review+
An SQLite user has reported a problem in one of the new optimizations added to the SQLite query planner for 3.19.0.  The problem is related to a new optimization for LEFT JOIN where the right-hand side of the join is a subquery or view.  Probably this does not affect FF (or otherwise we would have noticed before).  Nevertheless, you might want to hold off until 3.19.1 which will come out shortly.
Sounds good, thank you for the heads up, we'll wait 3.19.1.
hm, oh well, we'll just push on top.
Keywords: leave-open
Alias: SQLite3.19.0 → SQLite3.19.1
Summary: Upgrade to SQLite 3.19.0 → Upgrade to SQLite 3.19.1
Carrying over mak's previous r+ per IRC.
Attachment #8870236 - Attachment is obsolete: true
Attachment #8870918 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/33a1924fca18
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Blocks: SQLite3.19.2
You need to log in before you can comment on or make changes to this bug.