stylo: perspective animation does not work

RESOLVED DUPLICATE of bug 1335998

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1335998
9 months ago
9 months ago

People

(Reporter: shinglyu, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
Created attachment 8870662 [details]
moz-perspective.ogv

STR:
* Open http://demo.marcofolio.net/3d_animation_css3/
* The page uses "-webkit-perspective: 500;", but we don't support no-unit values, so use the devtool to modify it to "500px"
* Now the posters and the description card will be tilted
* Hover on the cards

Expected:
* The poster and the description card will rotate towards you

Actual:
* Only the poster rotates, the description card just jump to its final position and doesn't have the intermediate transition animation.

Version:

Version:
* commit 20ab6785cbd9da0af89da357cbef4f50c6a2afdf
* linux64 opt build

Updated

9 months ago
Blocks: 1288269

Updated

9 months ago
Duplicate of this bug: 1367290
Oops, I did paste wrong bug number there.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1335998
You need to log in before you can comment on or make changes to this bug.