stylo: transition is slower than gecko on the CSS Creates demo

RESOLVED DUPLICATE of bug 1367292

Status

()

P1
normal
RESOLVED DUPLICATE of bug 1367292
a year ago
a year ago

People

(Reporter: shinglyu, Assigned: hiro)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8870660 [details]
bouncing_jitter.ogv

STR: 

* Open http://bennettfeely.com/csscreatures/
* Observe the ones with bouncy movements
* Click the faces

Expected:
* Smooth animation
* When clicked, the ball will expand for a short period of time

Actual:
* Stylo's animation has significantly lower frame rate the gecko
* No animation when clicked

Version:
* commit 20ab6785cbd9da0af89da357cbef4f50c6a2afdf
* opt build on linux64
(Reporter)

Comment 1

a year ago
Created attachment 8870661 [details]
click_effect.ogv
From which day is the build? I know we enabled OMTA literally two days ago (bug 1334036). I assume there's a lot of difference potentially related to that.
Yeah, exactly.  But unfortunately it might be unrelated to. I see below warnings;

Animation of ‘transform’ cannot be run on the compositor because it should be synchronized with animations of geometric properties that started at the same time [div]
Summary: stylo: transition is slower then gecko on the CSS Creates demo → stylo: transition is slower than gecko on the CSS Creates demo
Assignee: nobody → hikezoe
Priority: -- → P1
The transition property is: "transition: .3s cubic-bezier(.15,.60,.30,1.9)".  We might be slower in case of "transition-property: all".  Another possibility is that if the transition is *NOT* started by clicking the element, it might be related to bug 1328505.
OK, I think this is because of mismatched transform list animations.
Depends on: 1365851
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1367292
You need to log in before you can comment on or make changes to this bug.