Search results matches in a tooltip pointing at buttons are still displayed even after clicking on any of the preferences category

VERIFIED FIXED in Firefox 55

Status

()

P1
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: hani.yacoub, Assigned: evanxd)

Tracking

(Blocks: 1 bug)

55 Branch
Firefox 55
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox53 unaffected, firefox54 unaffected, firefox55 verified)

Details

(Whiteboard: [photon-preference])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8870747 [details]
search_results.png

[Affected versions]: 
Nightly 55.0a1

[Affected platforms]:
Platforms:  Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. Launch Firefox, go to about:config and search for "browser.preferences.search" and set it value to true.
2. Go to "about:preferences".
3. Start typing to search for something (e.g default).
4. Click on "General".

[Expected result]:
Search results should be deleted after clicking on any preferences category.

[Actual result]:
Search results matches in a tooltip are still displayed even after clicking on any of the preferences category.
(Reporter)

Updated

2 years ago
Blocks: 1357285
Whiteboard: [photon-preference]
(Reporter)

Updated

2 years ago
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox55: --- → affected
(Assignee)

Updated

2 years ago
Assignee: nobody → evan
Status: NEW → ASSIGNED
Priority: -- → P1
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Attachment #8871624 - Flags: review?(mconley)
(Assignee)

Comment 3

2 years ago
Hi Mike,

Could you help review the patch?

Thanks.

Comment 4

2 years ago
mozreview-review
Comment on attachment 8871624 [details]
Bug 1367349 - Remove all tooltips after clicking on a preferences category.

https://reviewboard.mozilla.org/r/143116/#review146994

Seems okay - just need to fix a typo in the function name. Thanks!

::: browser/components/preferences/in-content/findInPage.js:368
(Diff revision 2)
> +  },
> +
> +  /**
> +   * Remove all search tooltips that were created.
> +   */
> +  removeAllSearchTooltops() {

Nit: removeAllSearchTooltops -> removeAllSearchTooltips
Attachment #8871624 - Flags: review?(mconley) → review+
(Assignee)

Comment 5

2 years ago
mozreview-review
Comment on attachment 8871624 [details]
Bug 1367349 - Remove all tooltips after clicking on a preferences category.

https://reviewboard.mozilla.org/r/143116/#review147000

::: browser/components/preferences/in-content/findInPage.js:368
(Diff revision 2)
> +  },
> +
> +  /**
> +   * Remove all search tooltips that were created.
> +   */
> +  removeAllSearchTooltops() {

Wrong spelling. Let's fix it.
Comment hidden (mozreview-request)
(Assignee)

Comment 7

2 years ago
Thanks for reviewing, Mike. I've updated the patch for the review comment.

Patch will be landed after the try[1] is good.

[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=117b09db81d8
Duplicate of this bug: 1368890
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 11

2 years ago
Rebased. Let's land the patch after the try[1] is good.

[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=5643e2f5bb67
Comment hidden (mozreview-request)
(Assignee)

Comment 13

2 years ago
There are many test failures in the previous try. Rabase and run again[1].

[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=68e02f46fba4
(Assignee)

Comment 14

2 years ago
The try at Comment 13 is good. Let's land the patch.
Keywords: checkin-needed

Comment 15

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2109d6a6d1c8
Remove all tooltips after clicking on a preferences category. r=mconley
Keywords: checkin-needed

Comment 16

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2109d6a6d1c8
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55

Comment 17

2 years ago
I have reproduced this Bug on Nightly 55.0a1 (2017-05-24)  on Windows 10, 64 Bit!

The bug's fix is now verified on latest  Nightly 55.0a1

Build ID 	20170604030205
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

[bugday-20170531]
(Reporter)

Comment 18

2 years ago
Build ID: 20170612091112
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Verified as fixed on Firefox Nightly 56.0a1 on Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
status-firefox55: fixed → verified
Flags: qe-verify+
QA Contact: hani.yacoub
You need to log in before you can comment on or make changes to this bug.