Closed Bug 1367875 Opened 3 years ago Closed 3 years ago

audio controls disappear if there is a brief dynamic change to a small "width"

Categories

(Toolkit :: Video/Audio Controls, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr45 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- wontfix
firefox54 --- wontfix
firefox55 --- fixed
firefox56 --- fixed

People

(Reporter: dholbert, Assigned: ralin)

References

(Blocks 1 open bug)

Details

(Keywords: regression, testcase)

Attachments

(2 files)

Attached file testcase 1
STR:
 1. Load attached testcase.

EXPECTED RESULTS:
Visible audio controls.

ACTUAL RESULTS:
Audio controls disappear after the JS tweak.


The testcase just sets the <audio> element to an extremely small width, and then undoes that change.  This brief visit to a small width seems to break the element permanently.

mozregression says this regressed as part of the video/audio controls rewrite in bug 1271765.
Flags: needinfo?(ralin)
(It's possible this bug & bug 1367846 are the same issue under the hood; not sure.)
See Also: → 1367846
It's not exact the same issue as 1367846 and bug 1362146. The controls should recovery from the "hide" state to normal size once undo the size constraints. I'll deal with bug 1362146 first, and then this. Thanks :)
Flags: needinfo?(ralin)
Depends on: 1362146
Too late to fix for 53, may be a bit late for 54 but if you get a fix and can verify it please request uplift.   Ray, want to assign this bug to yourself if you intend to work on it?
Flags: needinfo?(ralin)
I am thinking to fix those size adjusting issues at once, so no harm to take this as I've already on bug 1362146. Thank you Liz.
Assignee: nobody → ralin
Status: NEW → ASSIGNED
Flags: needinfo?(ralin)
Blocks: 1368639
No longer depends on: 1362146
Too late for 54. Mark 54 won't fix.
Tested with 56.0a1 (2017-07-03) (64-bit) on Mac, and it looks like this issue has been fixed by Bug 1373537. It's good to have a reftest nonetheless.
Comment on attachment 8883204 [details]
Bug 1367875 - Add a reftest about brief dynamically chaning <audio> to a small width.

https://reviewboard.mozilla.org/r/154144/#review159624
Attachment #8883204 - Flags: review?(jaws) → review+
Thanks for the review.

In order not to conflict with reftest.list, I'll land this after Bug 1367868.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a3c423b4ab94
Add a reftest about brief dynamically chaning <audio> to a small width. r=jaws
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/a3c423b4ab94
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.