Closed Bug 1495833 Opened Last year Closed Last year

audio controls grow back to a bigger size if there is a brief dynamic change to a small "width"

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 --- fixed

People

(Reporter: timdream, Assigned: timdream)

References

(Blocks 1 open bug, )

Details

(Keywords: regression)

Attachments

(1 file)

I've regressed bug 1367875 in bug 1493525 because UA Widget isn't covered by the reftest yet (to be done in bug 1483656).

The URL demonstrate the regression. The width of the two audio element should be the same.

It won't happen if you pref'd off UA Widget.

I dug a little bit more in adjustControlSize() and found other bugs. For the purpose of unblock bug 1483656, I am filing the separately (blocking bug 1368639) and focusing on fixing the one regression here.
This fixes a regression caused by bug 1367875 and detectable by
the reftest added in bug 1367875.

The width sizing of <audio> is still broken, see bug 1495821.
Pushed by tchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/039c4b2029a4
Allow <audio> to go back to the intrinsic control size r=jaws
https://hg.mozilla.org/mozilla-central/rev/039c4b2029a4
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.