Closed Bug 1367909 Opened 3 years ago Closed 3 years ago

Sidebar switcher background hover should be the width of the item (not the full width of the container)

Categories

(Firefox :: General, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 55
Iteration:
55.7 - Jun 12
Tracking Status
firefox55 --- fixed
firefox57 --- verified

People

(Reporter: abenson, Assigned: Gijs)

References

Details

(Whiteboard: [photon-structure])

Attachments

(1 file)

Currently, the hover effect for the sidebar switcher spans the whole width of the container (which looks odd). Let's change it so the background color is only as wide as the icon+label+down arrow.

See the updated spec, here (very bottom): https://mozilla.invisionapp.com/share/TPBBJYIZ3#/231191185_Explainer_-_Sidebar
Whiteboard: [photon-structure] → [photon-structure] [triage]
Flags: qe-verify+
Priority: -- → P2
QA Contact: gwimberly
Whiteboard: [photon-structure] [triage] → [photon-structure]
... and one more time for the right spec link: https://mozilla.invisionapp.com/share/ENBBK0F9U#/235741003_Explainer_-_Sidebar
Blocks: 1368973
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 55.7 - Jun 12
Priority: P2 → P1
Comment on attachment 8875695 [details]
Bug 1367909 and bug 1368973 - fix sidebar header button cropping and hover state,

https://reviewboard.mozilla.org/r/147128/#review151324

Thanks!
Attachment #8875695 - Flags: review?(bgrinstead) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e36088242fac
and bug 1368973 - fix sidebar header button cropping and hover state, r=bgrins
https://hg.mozilla.org/mozilla-central/rev/e36088242fac
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Duplicate of this bug: 1368973
When verifying, please also verify bug 1368973 is fixed by this patch.
Duplicate of this bug: 1368973
Blocks: 1387512
Verified on Windows, Mac, and Ubuntu.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.