Closed Bug 1368973 Opened 2 years ago Closed 2 years ago

Long page titles from web content loaded in the sidebar stretch the sidebar horizontally

Categories

(Firefox :: General, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 55
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 + verified

People

(Reporter: dao, Assigned: Gijs)

References

Details

(Keywords: regression, Whiteboard: fixed by bug 1367909)

Attachments

(1 file)

Attached image screenshot
No description provided.
Flags: qe-verify+
Priority: -- → P3
QA Contact: gwimberly
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
[Tracking Requested - why for this release]: See screenshot. This is quite broken.
Marco is this regression expected to stay in 55 when it moves to beta? (Or is it caused by something behind a photon pref?)
Flags: needinfo?(mmucci)
(In reply to David Bolter [:davidb] from comment #3)
> Marco is this regression expected to stay in 55 when it moves to beta? 

Yes, that's why it's tracked.
Flags: needinfo?(mmucci)
I put up a patch on bug 1367909.
Depends on: 1367909
This got fixed in bug 1367909.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1367909
Should get this verified specifically since bug 1367909 doesn't explicitly cover it.
Resolution: DUPLICATE → FIXED
Whiteboard: [reserve-photon-structure] → [reserve-photon-structure] fixed by bug 1367909
Target Milestone: --- → Firefox 55
(In reply to Dão Gottwald [::dao] from comment #7)
> Should get this verified specifically since bug 1367909 doesn't explicitly
> cover it.

... and I specifically asked for that in bug 1367909. Please don't change the resolution. Whether this was fixed separately or with the same patch makes a difference for capacity / reserve maths, and so pretending it was fixed separately doesn't make sense.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1367909
(In reply to :Gijs from comment #8)
> (In reply to Dão Gottwald [::dao] from comment #7)
> > Should get this verified specifically since bug 1367909 doesn't explicitly
> > cover it.
> 
> ... and I specifically asked for that in bug 1367909.

Hadn't seen this. That's fine as long as it doesn't get lost, and ensuring this is easier in a separate bug.

> Please don't change
> the resolution. Whether this was fixed separately or with the same patch
> makes a difference for capacity / reserve maths, and so pretending it was
> fixed separately doesn't make sense.

*sigh* Bugzilla isn't just a place to upload patches, it's an issue tracker too. It helps us ship quality software. I wasn't pretending this was fixed separately, but insisting that it's a separate issue. We should fix whatever formula dictates that we cannot track this separately. For now, I'll just remove this from your photon radar to enable normal bugzilla and release tracking workflow.
Resolution: DUPLICATE → FIXED
Whiteboard: [reserve-photon-structure] fixed by bug 1367909 → fixed by bug 1367909
Flags: qe-verify+
QA Contact: gwimberly
o_O

Correct me if I'm wrong, but I believe qe‑verify is still used outside of the photon project. Or maybe I'm supposed to use verifyme here, not sure. Or maybe tracking+ already ensures QA attention? Adding the flag and keyword to be on the safe side.
Flags: qe-verify+
Keywords: verifyme
Assignee: nobody → gijskruitbosch+bugs
I've reproduced the issue on Nightly 55.0a1 (2017-05-31).
Verified fixed on Windows 7 x64, Ubuntu 14.04 x64 and Mac OSX 10.12.5 using Firefox 55 Beta 3 (buildID:  	20170619071723).
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.