Closed Bug 1368024 Opened 3 years ago Closed 2 years ago

Web Apps - Fall back to 'name' when 'short_name' is missing

Categories

(Firefox for Android :: Web Apps (PWAs), defect, P1)

55 Branch
ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox55 --- affected
firefox58 --- verified

People

(Reporter: oana.horvath, Assigned: cnevinchen)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [FNC][SPT58.2][MVP][pwa-front-end])

Attachments

(1 file)

Devices:
-Huawei Honor 8 (Android 6.0);
-HTC Nexus 9 (Android 7.1.1);

Build: Nightly 55.0a1 (2017-05-24);

Steps to reproduce:
1. Install https://podle.audio/v7/ or paperplanes.world as PWA.
2. Check the PWA's title on the home screen. 

Expected result:
The title should be the one found in the manifest file. Both apps have names specified in the manifest.

Actual result:
Both apps have names specified in the manifest, but they are installed with the url instead of a name.

Notes:
Not reproducing on Chrome.
Blocks: 1285858
Assignee: nobody → dale
Information from IRC, root cause is: "we only use short_name then fall back to url, we should short_name || name || start_url ".
Will restart again when GeckoView pwa lands
Assignee: dale → nobody
I can reproduce this. Needs fixed. Wesly can you get an assignee?
Flags: needinfo?(wehuang)
Priority: -- → P1
Summary: Web Apps - Some web apps have an URL instead of title → Web Apps - Fall back to 'name' when 'short_name' is missing
let's see if we can get this done in the 58 Nightly cycle.

If not all the PWA frontend work in 58 nightly, then need to prioritize it with Joe/Andreas.
Flags: needinfo?(wehuang) → needinfo?(cnevinchen)
Whiteboard: [pwa-front-end]
Assignee: nobody → cnevinchen
Flags: needinfo?(cnevinchen)
Attachment #8915488 - Flags: review?(dharvey)
Comment on attachment 8915488 [details]
Bug 1368024 - Fall back to 'name' when 'short_name' is missing.

https://reviewboard.mozilla.org/r/186704/#review192216

Looks good cheers
Attachment #8915488 - Flags: review?(dharvey) → review+
Pushed by nechen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c879c334aa29
Fall back to 'name' when 'short_name' is missing. r=daleharvey
https://hg.mozilla.org/mozilla-central/rev/c879c334aa29
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Whiteboard: [pwa-front-end] → [FNC][SPT58.2][MVP][pwa-front-end]
Verified using the steps in Comment 0. The name is properly displayed now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.