Return receipt - Broken Subject line with national characters

VERIFIED FIXED

Status

MailNews Core
MIME
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Adam Macznik, Assigned: Navin Gupta)

Tracking

(Blocks: 1 bug, {intl})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2 rtm] [fix to trunk])

Attachments

(6 attachments, 2 obsolete attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020410
BuildID:    2002041011, Mozilla 1.0.0 branch build.

I have sent myself a message with national characters in the subject line,
requesting the MDN return receipt. When the message arrived, I let Mozilla to
send back the receipt. As a receipt came, it was broken because some header info
got between the subject lines (the subject was divided into two lines and the
second line appeared after some headers added by server).
I will try to add some testcase to make things clear.

Reproducible: Always
Steps to Reproduce:
1.Send e-mail with ISO 8859-2 characters in the subject line (to yourself),
request a return receipt. Make this subject rather long (about 50 chars).
2.Allow to send the receipt when the message arrives.
3.Get the receipt and watch it's contents

Actual Results:  The contents starts with part of the subject (it's second
line). The contents is displayed as a plain text message, not formatted in parts
like return receipts.

Expected Results:  Get a regular return receipt.

Of course the wrong display is caused by misinterpreting message headers, as the
given attachments will show.
I tested this with long subject with only ascii characters and it worked fine.
(Reporter)

Comment 1

16 years ago
Created attachment 78673 [details]
Message with national characters in the subject line

The message I sent to myself. It contains some ISO 8859-2 characters in the
subject line.
(Reporter)

Comment 2

16 years ago
Created attachment 78674 [details]
Return receipt with broken subject

This is the return receipt I got after viewing the message. Note the empty line
before the second subject line.

Updated

16 years ago
QA Contact: gayatri → gchan
Jeff, will you take care of that problem?

Comment 4

16 years ago
Taking ....
Assignee: ducarroz → jt95070

Comment 5

16 years ago
Accepting ...
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 6

16 years ago
Marina, do you see the problem on windows?
Keywords: intl

Comment 7

16 years ago
Created attachment 79004 [details]
A screen shot.

I kind of can reproduce the problem with a Simplified Chinese mail. In my case,
the long subject display is cut off, but the message source shows that there
are multiple line of subject header there.

Comment 8

16 years ago
Created attachment 79005 [details]
The return receipt for that Chinese mail with long subject line.

Comment 9

16 years ago
Created attachment 79011 [details]
Mesg source of Return Receipt w/ISO 8859-2 characters

Alex, are you still seeing this problem? I've set my char coding to
ISO 8859-2 and even tried your exact same subj line. But My Return
Receipt is all in one line. Tested 2002041011 commercial branch build.

Comment 10

16 years ago
QA contact to me.
QA Contact: gchan → ji

Comment 11

16 years ago
i see this problem on windows with a long subject line which is cut off.The
beginning of the subject is on the subject line and then it is displayed in the
message body as quoted printabale. In the source however we see it in the
subject line.

Comment 12

16 years ago
Created attachment 79578 [details] [diff] [review]
Patch ready for review and super-review

Please review and super-review. It would be nice to have it fixed in nsbeta1 or
RTM.
(Reporter)

Comment 13

16 years ago
Please review this patch. From the layman's point of view (well, I am a
programmer, but not a Mozilla programmer), it seems to be clear and rather
narrow. Jeff, maybe if you provided a diff it would help the reviewers?

This bug may be very visible when using receipts in international environment.

Comment 14

16 years ago
Adding nsbeta1 based on Jeff's comments.
Keywords: nsbeta1

Comment 15

16 years ago
Adam, the patch is attached to the bug on 4/16 and waiting for review.
Jeff, the last patch doesn't seem to be a diff!

Comment 17

16 years ago
Created attachment 80402 [details] [diff] [review]
proposed fix

here's the diff, created by saving Jeff's attachment and diff'ing it.

Comment 18

16 years ago
Created attachment 80404 [details] [diff] [review]
whoops, diffed the wrong way

whoops, diff had the wrong sense - I think this is what Jeff intended.
Attachment #79578 - Attachment is obsolete: true
Attachment #80402 - Attachment is obsolete: true

Comment 19

16 years ago
Comment on attachment 80404 [details] [diff] [review]
whoops, diffed the wrong way

one problem with this patch is that it doesn't use the localized "[no subject]"
string - I'll see how hard it would be to fix that.

Updated

16 years ago
Attachment #80404 - Flags: review+
Comment on attachment 80404 [details] [diff] [review]
whoops, diffed the wrong way

R=ducarroz. Would be nice if instead of hardcoding "[no subject]" you could
reuse the defaultSubject string defined in composeMsg.properties but for that
you will propably need to define an id for it.

Comment 21

16 years ago
yes, see my comment above. I tried getting the string from the string bundle,
but I didn't what routine to call to convert the unicode string result to a mime
header.

Comment 22

16 years ago
Comment on attachment 80404 [details] [diff] [review]
whoops, diffed the wrong way

sr=bienvenu
Attachment #80404 - Flags: superreview+

Updated

16 years ago
Blocks: 139694
(Reporter)

Comment 23

16 years ago
Will this patch be checked into the 1.0 branch?
No longer blocks: 139694

Comment 24

16 years ago
If someone tells me I can/should...

Updated

16 years ago
Blocks: 134040
(Reporter)

Updated

16 years ago
Blocks: 139694

Comment 25

16 years ago
impact summery:
impact language users- 339M potential users or 59.8% of the total internet users
who are not use English as their native language.
Visibility: The beta user themself won't see the problem. But the person who
send them mail and request for receipt will see the problem. 
Severity: this will break one major enterprise feature (MDN) usage outside
English speaking users. The essential information (which message got received by
the receiver) will be lost. We should consider this as data lost. 
work around: None

putterman: 
can you put a [adtx] and or nsbeta1+ on the status whiteboard ?

Comment 26

16 years ago
Please check this into the trunk so we can get some testing on it.
Keywords: nsbeta1 → adt1.0.0, nsbeta1+
Whiteboard: [adt2 rtm]

Comment 27

16 years ago
David has checked in the fix to the trunk. Thanks David.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Whiteboard: [adt2 rtm] → [adt2 rtm] [fix to trunk]

Comment 28

16 years ago
adding adt1.0.0+.  Please get drivers approval and then check into the 1.0 branch.
Keywords: adt1.0.0 → adt1.0.0+

Comment 29

16 years ago
changing to adt1.0.1+ for checkin to the 1.0 branch for the Mozilla1.0.1
milestone.  Please get drivers approval before checking in.
Keywords: adt1.0.0+ → adt1.0.1+

Comment 30

16 years ago
please checkin to the 1.0.1 branch ASAP. once there please remove the
mozilla1.0.1+ keyword and add the fixed1.0.1 keyword.
Keywords: mozilla1.0.1+

Updated

16 years ago
Attachment #80404 - Flags: approval+

Comment 31

16 years ago
David or Navin, can you check this in for Jeff?

Comment 32

16 years ago
reopening so I can reassign.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 33

16 years ago
Navin, can you check this onto the 1.0.1 branch?
Assignee: jt95070 → naving
Status: REOPENED → NEW

Comment 34

16 years ago
marking fixed again.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 35

16 years ago
Is proposed fix the right patch here? "whoops, diffed the wrong way" has r/sr/a
and it seems to be already there. 

Comment 36

16 years ago
I guess I already checked it into the branch.
Keywords: mozilla1.0.1+ → fixed1.0.1

Updated

16 years ago
QA Contact: ji → marina

Comment 37

16 years ago
QA contact to marina. Thanks.

Comment 38

16 years ago
verified with 2002-08-01-1.0 build, the return receipt displays correctly on
RedHat7.2 with central-european chars (8859-2). Adam, is it working for you as
well? Thanks.
Status: RESOLVED → VERIFIED
Keywords: verified1.0.1
(Reporter)

Comment 39

16 years ago
> Adam, is it working for you as well?
Yes, verified with Moz 1.1a and 1.1b on RedHat 7.1 - works OK.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.