Firefox version 53.0.3 appears high memory, high resources usage and might causing for SSD damages

RESOLVED DUPLICATE of bug 1346556

Status

()

P1
critical
RESOLVED DUPLICATE of bug 1346556
a year ago
a year ago

People

(Reporter: vbirloudis, Unassigned, NeedInfo)

Tracking

53 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170518000419

Steps to reproduce:

Hello,
Mozilla uses high resource and lagging, I have been reported this issue continuesly for couple of months in bugzilla but this issue has not fixed yet after too many firefox's upgrades. 


Actual results:

Mozilla Firefox it is caching all of this data 4-5GB on my new SSD and its lost 4%  from its health within 5 months, due continusesly writes/overwrites firefox cache on my SSD. When I tried to setup firefox to don't caching and reducing its cache size as result firefox had continuesly crashes because he was not able to write on my SSD.


Expected results:

Your technicians it had to resolve this issue before firefox's users starts taking legal actions against mozilla foundation. I am very upset about this issue and I have to advice my lawyer about that.
(Reporter)

Comment 1

a year ago
Created attachment 8872142 [details]
memory-report.json.gz
(Reporter)

Updated

a year ago
Alias: memshrink
OS: Unspecified → Windows 10
Priority: -- → P1
Hardware: Unspecified → x86_64
Whiteboard: MemShrink
(Reporter)

Updated

a year ago
Severity: normal → critical

Comment 2

a year ago
Hey Erahm, 
we have the memory report. Any comment/input? Thanks
Flags: needinfo?(erahm)

Comment 3

a year ago
I can't speak to SSD usage, is there a reason you believe Firefox is using 4-5GB of "cache"? How are you measuring that?

I feel like we've gone through this before, but just to reiterate:

  1) Can you provide a list of addons you have installed from about:support
  2) Can you disable all of your addons and see if that fixes your performance issues? Please follow these steps [1] to fully disable Kaspersky. If that works, you can selectively re-enable your add-ons in order to figure out which one is causing you problems.
  3) If that doesn't work can you try a Firefox refresh? [2]

I understand that disabling all of your add-ons isn't a great long term solution, but it will help us narrow down the issue.

For example I tried loading the linux-team forum and got:

> 58.21 MB (100.0%) -- explicit
> ├──16.90 MB (29.04%) ++ window-objects/top(http://linux-team.forumgreek.com/forum, id=2147483649)

[1] https://superuser.com/a/1019474
[2] https://support.mozilla.org/kb/refresh-firefox-reset-add-ons-and-settings
Flags: needinfo?(erahm)

Updated

a year ago
Alias: memshrink
(Reporter)

Comment 4

a year ago
Hello,
I have been tried the steps 1,2,3 too many times with current and previous versions of firefox (from 50 until current) without results and I have submitted the memory reports here. I have repeat the above steps at the past for few months without any solution from mozilla's side. The problem is appearing when you have firefox web browser opened for a lot of hours (at least 4-5 hours). Time by time you can see the memory leakage with softwares or with firefox measuring tool. After this period (4-5 hours) with about 12-15 tabs opened you can see the memory leakage of firefox. I am trying to understand what is happening to firefox and the RAM memory is overloading. I believe that something is going wrong with its memory allocation such this problem is not appearing on I.E, Microsoft Edge, Google Chrome and Opea web-browsers. As I watched more carefully the problem appeared when firefox started supports the HTTPS (SSL) certificates on websites. Now about the SSD as you know very well every web browser is caching some files in its "hidden" memory called cache memory and it is storing in HDD or SSD which drive is the web browser installed. Every website which is loading in web-browser it is downloading some parts of website on this cache. By this way its writing and overwriting the website's data (images and other contents) on the hard disk. When the web browser is caching these data again and again on SSD disk that means it is destroying its cells especially on SSD type TLC (Tripple Level Cells) or previous SSDs technologies such they have limits during writing and overwriting. Each cell has a specific number of writes and when this limit reached the cell it is destroying and the data moving by SSD's controller to other available cells. You can imagine if my web browser's daily caching(writing/overwriting data) on SSD which are reaches 4-5GB, my SSD's spanlife will be reduced dramatically just in a few months such SSDs average writes are only some TB(TerraBytes). That is a critical issue and mozilla must be fix it as soon as possible. The SSDs are very expensive disks as you know and the users are not able to replace them very often due their costs.
(Reporter)

Comment 5

a year ago
Hello,
Last night I was left my PC open and the firefox overloaded my RAM and then it stucked :(. I was closed it and when I reopen it today firefox shows the message "Firefox process was not terminated its process" and the dialog box had a button "Close Firefox", and I was pressed it. After that the firefox released about 6GB of RAM and then opened again normally. Can you check please in firefox source code the whole memory allocation procedures and / or functions please?
Hello, Thanks for posting the about:memory report as the gzipped file, it is much move convenient that way.

== Real problem ?==  - ABP - Fix in Fx55+ ?
There is some indication that the support forum has received more than normal numbers of questions about Windows particularly W7 being slow or using large amounts of memory. I keep reminding myself and others that some of these issues are hard to track down, they may affect only a small minority percentage wise but that is potentially thousands or millions of individuals. 
Some of the problems may relate to two issues with the very popular ABP addon: bug 1369655 comment6 & previously Bug1336811 and it appears those have been resolved.

One user of Firefox [*] is suggesting a particular issue may have been resolved in Fx55+ so you may wish to test out using Firefox Nightly. It is a longshot but you may just be lucky and discover this problem is no longer present in the latest Firefox Nightlies.
Note you may install Nightly as an additional browser from https://www.mozilla.org/firefox/channel/desktop/#nightly

== Further Information ==
You are reporting what appears to be a very important problem, but fortunately for some; an issue that many Firefox users do not see. I realise it is frustrating when you see a real issue and you are then asked for further information but if you could find the time to answer the questions in comment 3 it may well help with progress in investigating this issue.
  
I know you have provided a lot of other information, but I note you did not follow up directly on:
bug1346556 commnet27 
>Is this still an issue with 53 (currently beta, next week on release)?
And
bug1354880 comment11
>Hi,
>Marking this as Resolved: Incomplete due to the lack of response from Vbirloudis.
>If the issue is still reproducible with the latest Firefox version, feel free to reopen the bug with more information.

[*]Support threads
https://support.mozilla.org/questions/1160417#answer-978741
https://support.mozilla.org/questions/1164332#answer-978347
See Also: → bug 1354880, bug 1346556
Whiteboard: MemShrink → [MemShrink]

Updated

a year ago
Flags: needinfo?(vbirloudis)

Comment 7

a year ago
Adding needinfo flag for comment 6.
See Also: bug 1346556
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1346556
You need to log in before you can comment on or make changes to this bug.