Closed Bug 1368364 Opened 3 years ago Closed 3 years ago

Intermittent browser_BrowserUITelemetry_syncedtabs.js,browser_PermissionUI.js | application terminated with exit code 11 after Non-local network connections are disabled and a connection attempt to www.undefined.com...

Categories

(Toolkit :: Telemetry, defect)

55 Branch
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Assigned: jmaher)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(1 file)

https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&noautoclassify&fromchange=021d6fb6bd8c3db50f34218ca0c158a739636901&group_state=expanded&filter-searchStr=linux%20debug%20browser-chrome&tochange=5809a30a0c4817509beb1078cf336d8367b8107a says this started with the landing of bug 1242505, but because that also moved it from bc9 to bc11, it may have started as a direct effect of those patches, or it may have started just because they don't like their new home in bc11.
Blocks: 1242505
I don't see how the changes in bug 1242505 could make an existing test attempt a new network connection, or cause an existing variable to be undefined, which might be what's happening here, so as you noted the relationship might be indirect. The failure doesn't have a useful stack trace, so it might not be trivial to debug.
Summary: Intermittent browser/modules/test/browser/browser_BrowserUITelemetry_syncedtabs.js | application terminated with exit code 11 after Non-local network connections are disabled and a connection attempt to www.undefined.com... → Intermittent browser_BrowserUITelemetry_syncedtabs.js,browser_PermissionUI.js | application terminated with exit code 11 after Non-local network connections are disabled and a connection attempt to www.undefined.com...
Duplicate of this bug: 1368634
pushing to try with a backout of 1242505:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=bf0fe0b6895837d35aeb38de40a4341a33b34b26

if this fixes the problem, then I will ask the sheriffs to back this out as we have ~120 failures in 6 days so far and nobody is taking ownership of investigating or fixing this bug.
Whiteboard: [stockwell needswork]
Given that we're close to code freeze, a plain backout of bug 1242505 might be the right solution if this fixes the intermittent failures, and I'll investigate this at the beginning of the following cycle, after the code freeze is lifted.
with the backout, I see:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=bf0fe0b6895837d35aeb38de40a4341a33b34b26&selectedJob=104152970&filter-searchStr=x64%20bc2

the bc2 errors are the key- the failures annotated for this bug are in the browser/modules/test/browser/ directory, but we get a external network connection attempt.

I see failures in the same directory, but no mention of external network connection.  We could backout and work on this after the fact?  I am still waiting for another 30 jobs to finish.
ok, all try jobs finished, I think backing this out solves the problem- happy to wait and fix this early next week, or back it out now and land it when we can.
:gbrown, do you interpret the data the same way I am?
Flags: needinfo?(gbrown)
Yes - backout seems to eliminate this failure.
Flags: needinfo?(gbrown)
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/mozilla-inbound/rev/90df8b3f52d6
backout bug 1242505 as it causes browser/modules/ intermittent failures. r=paolo
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Version: unspecified → 55 Branch
Attachment #8874044 - Flags: review?(paolo.mozmail) → review+
Whiteboard: [stockwell needswork] → [stockwell fixed]
Depends on: 1373549
Assignee: nobody → jmaher
You need to log in before you can comment on or make changes to this bug.