If Nightly is unfocused - the search suggestions hint is not displayed for 4 times anymore

VERIFIED FIXED in Firefox 55

Status

()

defect
P2
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: simona.marcu, Assigned: mak)

Tracking

55 Branch
Firefox 55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 unaffected, firefox54 unaffected, firefox55 verified)

Details

(Whiteboard: [fxsearch])

Attachments

(2 attachments)

[Affected versions]:
- Nightly 55.0a1
 
[Affected platforms]:
- All
 
[Steps to reproduce]:
1. Launch Firefox with a new profile
2. Focus the Awesome bar by mouse click
3. Unfocus the Awesome Bar, and open a new tab
4. Unfocus the Awesome Bar again
5. Open a new Window and start typing in the URL bar 
6. Unfocus the 2 Firefox windows (click on your Desktop)
7. Close the Window opened in step 4 (by clicking the X)
8. Close the Window opened in step 1 (by clicking the X)
9. Reopen Firefox
10. Dismiss the Nightly is not your default browser by clicking on the "Not Now" button
11. Focus the Awesome Bar and start typing.

 
[Expected result]:
- The Search Suggestions hint should be displayed 4 times - in steps: 2, 3, 5 and 11
  
[Actual result]:
- The Search Suggestions hint is not displayed in step 11, and neither is after that, regardless if I open new tabs, windows, and sessions.
 

[Additional notes]:
- If Firefox is not unfocused in step 6 and I simply dismiss the hint by clicking anywhere on the page, the hint is properly displayed in step 11.
Whiteboard: [fxsearch]
Another scenario, much straight forward:
1. Launch Firefox with a new profile
2. Focus the Awesome bar
3. Unfocus the Firefox window
4. Close Firefox
4. Re-launch Firefox
5. Repeat steps 2-4 
6. Focus the Awesome Bar

Actual results: Step 6 - The hint is not displayed anymore (it was displayed only twice). Please see the screencast for more details.
Summary: If Nightly is unfocused - the search suggestions hint is displayed only 3 times → If Nightly is unfocused - the search suggestions hint is not displayed for 4 times anymore
Priority: -- → P2
Please note that it is not necessary to open a new Firefox Window to reproduce this issue.
Steps to reproduce:
1. Launch Firefox with a new profile and focus the Awesome Bar
2. Unfocus the Firefox window (click on your desktop)
3. Open a new tab and start writing in the Awesome Bar
4. Unfocus the Firefox window (click on your desktop)
5. Open a new tab and start typing in the Awesome Bar.

Expected results: The search suggestions hint should be displayed in steps 1, 3 and 5. 
Actual results: The search suggestions hint is displayed in steps 1 and 3 but it's not displayed in step 5 and neither is from that point over.
Assignee

Comment 3

2 years ago
taking for investigation
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Assignee

Comment 4

2 years ago
I suspect this is related to bug 1370518, when you open a new tab (I assume clicking on the button, since the window is unfocused) we should show the notification since the location bar gets focus, but due to that bug we don't. Then you start typing and we DO show it. That means we subtract TWICE instead of once.
Depends on: 1370518
Assignee

Comment 5

2 years ago
The other problem is this:
http://searchfox.org/mozilla-central/rev/d441cb24482c2e5448accaf07379445059937080/browser/base/content/tabbrowser.xml#1338
we open the popup to show the notification, but the tabbrowser decides to close it for the tab switch.
Comment hidden (mozreview-request)
Assignee

Comment 7

2 years ago
even bypassing the problem in comment 3, the platform sometimes just doesn't open the popup. I investigated down to the xul popup manager, and that far everything was fine. From that point on the investigation is just more expensive than the benefit, so I made frontend code only count real impressions.
Assignee

Comment 8

2 years ago
Sorry. comment 7 link should have said: the problem in comment 5
Comment on attachment 8875270 [details]
Bug 1368470 - Count search suggestions notification impressions only when the popup is really shown.

https://reviewboard.mozilla.org/r/146666/#review151282

Agreed that this approach is strictly better than assuming the poup will show.
Attachment #8875270 - Flags: review?(past) → review+

Comment 10

2 years ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/a9e45f56795b
Count search suggestions notification impressions only when the popup is really shown. r=past

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a9e45f56795b
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Verified on Ubuntu 16.04 x64 that the scenarios from Comment 1 and Comment 2 are no longer reproducible. Waiting for Bug 	1370518 to be fixed before marking this issue as verified since I can't follow the exact steps from the Description (because of Bug 1370518).
Assignee

Updated

2 years ago
Component: Search → Location Bar
Verified as fixed with latest Beta 55.0b9, build ID 20170713130618 on Windows 10 x64, Ubuntu 16.04 and Mac OS X 10.12.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.