Closed Bug 1372536 Opened 5 years ago Closed 4 years ago

The search suggestions hint is not displayed 4 time if the window is unfocused

Categories

(Firefox :: Address Bar, defect, P3)

55 Branch
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox55 --- affected
firefox56 --- affected

People

(Reporter: simona.marcu, Unassigned)

References

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

[Affected versions]:
- Nightly 55.0a1
 
[Affected platforms]:
- Windows 10 and Ubuntu 16.04
 
[Steps to reproduce]:
Ubuntu:
1. Launch Firefox with a new profile
2. Focus the Awesome Bar
3. Unfocus the Nightly window by clicking twice on your Desktop
4. Close Nightly by clicking on the "x" button
5. Re-launch Nightly
6. Focus the Awesome Bar
7. Unfocus the Nightly window by clicking twice on your Desktop
8. Close Nightly by clicking on the "x" button
9. Re-launch Nightly
10. Focus the Awesome Bar

Windows 10:
1. Launch Nightly with a new profile
2. Focus the Awesome Bar
3. Click once on your desktop to unfocus the Nightly window
4. Close Nightly by clicking on the "x" button
5. Re-launch Nightly
6. Focus the Awesome Bar
7. Repeat steps 3, 4 and 5
8. Focus the Awesome bar
9. Repeat steps 3, 4 and 5
10. Focus the Awesome Bar


[Expected result]:
Ubuntu: Steps 2, 6 and 10: the search suggestions hint should be properly displayed.

Windows: Steps 2, 6, 8 and 10 the search suggestions hint should be properly displayed. 
 
[Actual result]:
Ubuntu: The search Suggestions hint is displayed only twice (in steps 2 and 6). The hint is not displayed in step 10 and neither is from that point further. Please see the screencast for more details: 
https://people-mozilla.org/~aflorinescu/simona/vokoscreen-2017-06-12_18-07-55.mkv

Windows: The search suggestions hint is displayed only 3 times (in steps 2, 6 and 8). The hint is not displayed in step 10. 
 

[Additional notes]:
- Could not reproduce this issue on Mac OS X.
Could you please file bugs under the Location Bar component rather than Search?

Btw, I tried to reproduce this on Windows 10 and I couldn't, the hint has been shown to me at steps 2, 6, 8 and 10.
I used the mouse to focus the awesomebar.
Was this a build including all the latest fixed, that is bug 1368470 AND bug 1370518?
Component: Search → Location Bar
Whiteboard: [fxsearch]
(In reply to Marco Bonardo [::mak] from comment #1)
> Could you please file bugs under the Location Bar component rather than
> Search?
> 
> Btw, I tried to reproduce this on Windows 10 and I couldn't, the hint has
> been shown to me at steps 2, 6, 8 and 10.
> I used the mouse to focus the awesomebar.
> Was this a build including all the latest fixed, that is bug 1368470 AND bug
> 1370518?

I can reproduce this issue regardless of the way I focus the Awesome Bar (by mouse click or by using the Keys Ctrl+L). Reproduced it on Nightly 55.0a1 (Build ID: 20170612030208) and on Nightly 56.0a1 (20170612091112) - on Windows 10 x64.
Priority: -- → P1
Reproduced the issue, using the above mentioned steps provided, on Beta Version 55.0b8 Build ID 20170710085521 Windows 10 x32 bit and Ubuntu 14.04 Build ID 20170710155419

[Steps to reproduce]:
Ubuntu:
1. Launch Firefox with a new profile
2. Focus the Awesome Bar
3. Unfocus the Nightly window by clicking twice on your Desktop
4. Close Nightly by clicking on the "x" button
5. Re-launch Nightly
6. Focus the Awesome Bar
7. Unfocus the Nightly window by clicking twice on your Desktop
8. Close Nightly by clicking on the "x" button
9. Re-launch Nightly
10. Focus the Awesome Bar

[Expected result]:
The search suggestions hint should be properly displayed 4 times.
[Actual result]:
The search Suggestions hint is displayed only once or twice

Windows 10:
1. Launch Nightly with a new profile
2. Focus the Awesome Bar
3. Click once on your desktop to unfocus the Nightly window
4. Close Nightly by clicking on the "x" button
5. Re-launch Nightly
6. Focus the Awesome Bar
7. Repeat steps 3, 4 and 5
8. Focus the Awesome bar
9. Repeat steps 3, 4 and 5
10. Focus the Awesome Bar

[Expected result]:
The search suggestions hint should be properly displayed 4 time.
[Actual result]:
The search Suggestions hint is displayed only 3 times
With the provided steps for Windows 10, I reproduce the bug on latest Nightly 56.0a1 on Windows 10 x64. The hint is displayed only 3 times instead of 4 times.
Panos, I have too many requests in queue currently to handle, I can't look into this any time soon.
Either we deprioritize, or find someone who may have time to look into this...
Flags: needinfo?(past)
Panos, we can de-prioritize to a 2 or a 3. We do want the hint to be seen, but we weren't super scientific about how many times.
OK, moving to P2 for now since everyone is swamped and we display the hint 4 times in the main workflows.
Flags: needinfo?(past)
Priority: P1 → P2
Retested on Version 55.0b10
Build ID 20170717064120

macOS 10.12 (Sierra)
Windows 7 x64

It seems that this issue has intermittent reproducibility.
Also, if the awesome bar is unfocused by clicking on the Desktop, and focused again in the same browser instance(by mouse click), the hint will no be displayed. For more details please check the attached screen record.
When you open the new tab, the urlbar was already focused and keeps being focused, so there's no focus change there, from a technical point of view. You should first blur it (maybe by clicking on content).
The same may be true for focusing the desktop, I don't know if our platform sends a focus event if the urlbar was already focused when the window lost focus. It sounds like it should, but I didn't check.

This is not important though, the bug is about the number of times the hint is shown. To check that, the location bar must be blurred and refocused.
Priority: P2 → P3
At this point I don't think fixing this has much value compared to its cost.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.