Crash in mozilla::dom::PaymentRequestBinding::_constructor

RESOLVED INVALID

Status

()

Core
DOM: Web Payments
--
critical
RESOLVED INVALID
9 months ago
3 months ago

People

(Reporter: calixte, Assigned: edenchuang)

Tracking

(Blocks: 2 bugs, {crash, regression})

55 Branch
Unspecified
Mac OS X
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 disabled)

Details

(Whiteboard: [clouseau], crash signature)

(Reporter)

Description

9 months ago
This bug was filed from the Socorro interface and is 
report bp-cce86fc7-6bc0-43bc-b20e-2f71b0170601.
=============================================================

There are 3 crashes in nightly 55 with buildid 20170531030204. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1345361.

[1] https://hg.mozilla.org/mozilla-central/rev/d2370b6a03e8
Flags: needinfo?(echuang)
(Assignee)

Comment 1

9 months ago
Currently we have already known that PaymentRequest API could crash under following situations.

1. Using PaymentRequest API when disable e10s. Here we have a bug 1365964 for non-e10s support.
2. When using PaymentRequest API with super large or some special input data. We also have bugs and web-platform-tests for these issues.

PaymentRequest API is a default off feature, that means to enable PaymentRequest API user must set preference.
And we do not finish whole API implementation, this could also make some problem when using PaymentRequest API.

So, I will take this bug, and to monitor it after all implementation and fixes of above bugs are landed.
Assignee: nobody → echuang
Flags: needinfo?(echuang)
This is disabled and we plan to remain the status on 55, so changing the firefox55-status to disabled.
status-firefox55: affected → disabled

Updated

8 months ago
Depends on: 1365964

Updated

8 months ago
Blocks: 1318987
No longer blocks: 1345361

Updated

7 months ago
Blocks: 1380546

Updated

7 months ago
No longer blocks: 1380546
(Assignee)

Comment 3

7 months ago
Since bug 1365964 is set as WONT_FIX, keeping this bug for tracking other crash issues after 57.
Blocks: 1396527
Closing, as per bug 1365964. If new issues come up, we can deal with them in new bugs.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.