Webrender update from bug 1367734 requires rustc 1.17

RESOLVED FIXED in Firefox 55

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

2 years ago
Simply applying the patch from https://github.com/servo/webrender/pull/1330 allows to build with supported versions of rustc (per configure)
Comment hidden (mozreview-request)
Assignee

Updated

2 years ago
Summary: Update from bug 1367734 requires rustc 1.17 → Webrender update from bug 1367734 requires rustc 1.17
I'm OK with landing this temporarily but if we are going to keep the minimum requirement for more than a couple of days we should upstream this into webrender too. We pull updates roughly once a week and I don't want to maintain local changes because it makes the updates harder. Could you submit a PR against servo/webrender on github as well?
Doh, I didn't see you already did that. I can't read apparently!

Comment 4

2 years ago
mozreview-review
Comment on attachment 8873700 [details]
Bug 1369615 - Avoid unnecessary struct field shorthand in webrender.

https://reviewboard.mozilla.org/r/145092/#review149190
Attachment #8873700 - Flags: review?(bugmail) → review+

Comment 5

2 years ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1e4caa4e405a
Avoid unnecessary struct field shorthand in webrender. r=kats
Duplicate of this bug: 1369707

Comment 7

2 years ago
Hi, I come from bug 1369707 :
There  we had this exchagne:
--- begin quote ---
(In reply to Andrew Osmond [:aosmond] from comment #1)
> Updating the rust compiler from 1.15 to 1.17 fixed this for me.

rustup update

did the trick, but pre-1.17 version of rust was the default configuration when we used
|mach bootstrap| so there is something amiss here.
Either webrender code needs to be updated or new versoin of rustc ought to be installed by |mach bootstrap| IMHO.

I will post this message to bug 1369615
--- end quote


I believe that the above patch here updates the webrender code.
Is there a plan to install newer version of rustc by |mach bootstrap| or related configuration command?
Obviously the developers seem to use much newer version of rustc than is required by configure, and I suspect this type of issue will crop up (for local build, too. And that hurts.)

For not losing precious developer man-hours, I vote for updating rustc by default if that is not a problem in itself.

TIA
Assignee

Comment 8

2 years ago
I think mach bootstrap installs the stable rustc version whenever you run it, so in practice, it should already install 1.17. Anyways, as of now, we have jobs that build with the minimum version supported for GCC, rustc and libclang, that will turn red if something like this happens again.

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1e4caa4e405a
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55

Comment 10

2 years ago
(In reply to Mike Hommey [:glandium] from comment #8)
> I think mach bootstrap installs the stable rustc version whenever you run
> it, so in practice, it should already install 1.17. 

Sorry I missed reading this comment earlier.
That was not quite what it did. 
It did not upgrade from 1.something to 1.17. I had to do the upgrade manually.
That is, I had already installed rustc according to some documentation.
But mach bootstrap did NOT upgrade to the latest stable version automagically.
This may be a problem.

> Anyways, as of now, we
> have jobs that build with the minimum version supported for GCC, rustc and
> libclang, that will turn red if something like this happens again.

Anyway, since the bug is filed and visible and the people who got hit by similar bugs in the future would know what to do.
You need to log in before you can comment on or make changes to this bug.