Build fails with " struct field shorthands are unstable (see issue #37340)" mozilla/gfx/webrender/src/renderer.rs:1061:13

RESOLVED DUPLICATE of bug 1369615

Status

()

Core
Graphics: WebRender
--
blocker
RESOLVED DUPLICATE of bug 1369615
6 months ago
6 months ago

People

(Reporter: ISHIKAWA, Chiaki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
After refreshing C-C source tree today on a local PC (linux), I encountered a local build failure of C-C TB.

It looks that there is a bug (?) of using a not well-defined semantics/syntax of rust.

The error is:


--- begin quote---
error: struct field shorthands are unstable (see issue #37340)
    --> /new-hd1/extra/ishikawa/TB-3HG/NEW-COMMSRC/mozilla/gfx/webrender/src/renderer.rs:1061:13
     |
1061 |             default_font_render_mode,
     |             ^^^^^^^^^^^^^^^^^^^^^^^^

error: aborting due to previous error

error: Could not compile `webrender`.

To learn more, run the command again with --verbose.
/new-hd1/extra/ishikawa/TB-3HG/NEW-COMMSRC/mozilla/config/rules.mk:1024: recipe for target 'force-cargo-library-build' failed
make[4]: *** [force-cargo-library-build] Error 101
--- end quote ---

This did not happen about 12 hours earlier, and so is quite new.

TIA
Updating the rust compiler from 1.15 to 1.17 fixed this for me.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1369615
(Reporter)

Comment 3

6 months ago
(In reply to Andrew Osmond [:aosmond] from comment #1)
> Updating the rust compiler from 1.15 to 1.17 fixed this for me.

rustup update

did the trick, but pre-1.17 version of rust was the default configuration when we used
|mach bootstrap| so there is something amiss here.
Either webrender code needs to be updated or new versoin of rustc ought to be installed by |mach bootstrap| IMHO.

I will post this message to bug 1369615
You need to log in before you can comment on or make changes to this bug.