improper rendering of list marker

VERIFIED DUPLICATE of bug 3935

Status

()

Core
CSS Parsing and Computation
--
minor
VERIFIED DUPLICATE of bug 3935
16 years ago
11 years ago

People

(Reporter: Stanislav Brabec, Assigned: dbaron)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Comparing results of Marker example 5 from Cascading Style Sheets, level 2, CSS2
Specification, W3C Recommendation 12-May-1998 with reference one, the
interpreter contains at least three differrences:
- content: counter... is ignored at all
- if content contains simple expression (e.g. "-"), it is rendered, but original
marker is not removed
- list item ignores P specs (it probably should be inherited, as can be deduced
from demonstation output).


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML>
<HEAD>
<TITLE>Marker example 5</TITLE>
<STYLE type="text/css">
P { margin-left: 8em } /* Make space for counters */
           LI:before { 
               display: marker;
               marker-offset: 3em;
               content: counter(mycounter, lower-roman) ".";
               counter-increment: mycounter;
           }   
      </STYLE>
</HEAD>
<BODY>
<P> This is a long preceding paragraph ...
     <OL>
<LI> This is the first item.
       <LI> This is the second item.
       <LI> This is the third item.
     </OL>
<P> This is a long following paragraph ...
   </BODY>
</HTML>
(Assignee)

Comment 1

16 years ago
This is basically a duplicate of bug 3935 since we shouldn't be trying to
support these properties.  They're unlikely to be in CSS3, anyway.
1)  We don't support counters yet
2)  <p> cannot contain <ol> -- it can only contain text content.  Hence the
rendering you see.


*** This bug has been marked as a duplicate of 3935 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
VERIFIED
Status: RESOLVED → VERIFIED

Comment 4

11 years ago
Linking to the current actuve bugs on this subject: display: marker won't be implemented (https://bugzilla.mozilla.org/show_bug.cgi?id=14983) -- instead mozilla will eventually "Support CSS3's ::marker pseudo element" (https://bugzilla.mozilla.org/show_bug.cgi?id=205202).
You need to log in before you can comment on or make changes to this bug.