Support ::marker pseudo element

NEW
Unassigned

Status

()

Core
CSS Parsing and Computation
P4
enhancement
14 years ago
3 months ago

People

(Reporter: Kim Scarborough, Unassigned)

Tracking

(Depends on: 2 bugs, Blocks: 4 bugs, {css3, dev-doc-needed})

Trunk
css3, dev-doc-needed
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.4a) Gecko/20030419
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.4a) Gecko/20030419

If bug 26710 is WONTFIX on the grounds that CSS3 won't use "display: marker",
then Mozilla should support what CSS3 *will* use, namely "li::marker" (see
<http://www.w3.org/TR/css3-lists/#markers>). Currently, there is no way in
Mozilla to make an ordered list like this (for instance):

1) Groucho
2) Chico
3) Harpo

Reproducible: Always

Steps to Reproduce:
Summary: Support CSS3 li::marker pseudo class → Support CSS3 li::marker pseudo element
Please don't file bugs for missing features. CSS3 Lists isn't in CR yet -- we
don't know for sure that ::marker will exist. Even if it did, CSS2.1 features,
and even more importantly, CSS2.1 bugs, are a much higher priority than CSS3.

Bugs for new features will be filed if someone implements them.

Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

13 years ago
Severity: normal → enhancement
Keywords: css3
Summary: Support CSS3 li::marker pseudo element → Support ::marker pseudo element

Updated

13 years ago
Blocks: 54979
Priority: -- → P1
Target Milestone: --- → Future

Updated

12 years ago
Depends on: 288704
QA Contact: ian → style-system
In the meantime, we have ::-moz-list-bullet (which is documented but will obviously never be a standard under that name) and ::-moz-list-number (which is not even documented yet). A personalized list like that mentioned in comment #0 can be achieved, but not easily, by means of CSS3 counters conforming to the current W3C "Draft recommendation": see bug 593739 comment #0 for a similar example with the "jumping through hoops" solution I found.
Assignee: dbaron → nobody
Priority: P1 → P4
Target Milestone: Future → ---
Blocks: 843718
Status: ASSIGNED → NEW
Does this still require bug 215083 in order to be implemented?
Flags: needinfo?(dbaron)
I don't think so.  Did it ever?

(Sorry for the delay responding.)
Flags: needinfo?(dbaron)
Blocks: 1024179
Keywords: dev-doc-needed
Blocks: 1221416
To support ::marker, I guess we'll need to support the name alias for pseudo element since ::-moz-list-bullet and ::-moz-list-number will become the aliases for ::marker. I don't found the similar alias mechanism like CSS properties.
Depends on: 1265639
Comment hidden (advocacy)
You need to log in before you can comment on or make changes to this bug.