Menulist items aren't highlighted

VERIFIED FIXED in Firefox 55

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: hani.yacoub, Assigned: rickychien)

Tracking

(Blocks 1 bug)

55 Branch
mozilla55
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox53 unaffected, firefox54 unaffected, firefox55 verified)

Details

(Whiteboard: [photon-preference])

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Posted image actual result.png
[Affected versions]: 
Nightly 55.0a1

[Affected platforms]:
Platforms: Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. Launch Firefox, go to about:config and search for "browser.preferences.search" and set it value to true.
2. Go to "about:preferences".
3. Search for "yahoo" in the search field.

[Expected result]:
Menulist items should be highlighted if they matched the keyword.

[Actual result]:
Menulist items aren't highlighted.
(Reporter)

Updated

2 years ago
Blocks: 1357285
Whiteboard: [photon-preference]
(Reporter)

Comment 1

2 years ago
Posted image expected result1.png
(Reporter)

Comment 2

2 years ago
Posted image expected result2.png
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Flags: qe-verify+
QA Contact: hani.yacoub
Whiteboard: [photon-preference] → [photon-preference][triage]
Comment hidden (mozreview-request)
Mike, I suspect this regression is due to bug 1352481 after resolving merge conflict. Please review it kindly thanks!
Priority: -- → P1

Comment 5

2 years ago
mozreview-review
Comment on attachment 8874284 [details]
Bug 1369704 - Menulist items aren't highlighted

https://reviewboard.mozilla.org/r/145652/#review149786

This looks okay, though note that [when the item is selected in the menupopup](http://i.imgur.com/XJ9Wd86.png), the highlight changes. Not sure if that's desirable or not, but thought I'd point it out - perhaps something worth running by UX.
Attachment #8874284 - Flags: review?(mconley) → review+
Thanks for bringing this up. I had a conversation on this topic with visual designer yesterday and here is latest "Search Highlights Visual" spec for this.

https://mozilla.invisionapp.com/share/P4ACQT1E3#/screens/237178978_6-1_Search_Highlights_Visual

I'll update the color within this patch. Thanks
Comment hidden (mozreview-request)

Comment 8

2 years ago
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dcc662d5a3cc
Menulist items aren't highlighted r=mconley
Whiteboard: [photon-preference][triage] → [photon-preference]
https://hg.mozilla.org/mozilla-central/rev/dcc662d5a3cc
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
(Reporter)

Comment 10

2 years ago
Build ID: 20170612091112
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Verified as fixed on Firefox Nightly 56.0a1 on Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.