Closed Bug 1370104 Opened 2 years ago Closed 2 years ago

Crash in core::result::unwrap_failed<T> | webrender::renderer::Renderer::draw_tile_frame

Categories

(Core :: Graphics: WebRender, defect, critical)

55 Branch
All
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed

People

(Reporter: philipp, Assigned: kats)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-53fc2e02-72a4-435d-b75e-401fc0170604.
=============================================================
Crashing Thread (9)
Frame 	Module 	Signature 	Source
0 	xul.dll 	std::panicking::rust_panic 	C:/projects/rust/src/libstd/panicking.rs:577
1 	xul.dll 	std::panicking::rust_panic_with_hook 	C:/projects/rust/src/libstd/panicking.rs:565
2 	xul.dll 	std::panicking::begin_panic<collections::string::String> 	C:/projects/rust/src/libstd/panicking.rs:511
3 	xul.dll 	std::panicking::begin_panic_fmt 	C:/projects/rust/src/libstd/panicking.rs:495
4 	xul.dll 	core::panicking::panic_fmt 	C:/projects/rust/src/libcore/panicking.rs:61
5 	xul.dll 	core::result::unwrap_failed<webrender::device::ShaderError> 	C:/projects/rust/src/libcore/macros.rs:29
6 	xul.dll 	webrender::renderer::Renderer::draw_tile_frame 	gfx/webrender/src/renderer.rs:2141
7 	xul.dll 	webrender_bindings::bindings::wr_renderer_render 	gfx/webrender_bindings/src/bindings.rs:771
8 	xul.dll 	mozilla::wr::RendererOGL::Render() 	gfx/webrender_bindings/RendererOGL.cpp:128
9 	xul.dll 	mozilla::wr::RenderThread::UpdateAndRender(WrWindowId) 	gfx/webrender_bindings/RenderThread.cpp:194
10 	xul.dll 	mozilla::wr::RenderThread::NewFrameReady(WrWindowId) 	gfx/webrender_bindings/RenderThread.cpp:132
11 	xul.dll 	mozilla::detail::RunnableMethodImpl<mozilla::dom::HTMLMediaElement::ChannelLoader* const, void ( mozilla::dom::HTMLMediaElement::ChannelLoader::*)(mozilla::dom::HTMLMediaElement*), 1, 0, mozilla::dom::HTMLMediaElement*>::Run() 	obj-firefox/dist/include/nsThreadUtils.h:1133
12 	xul.dll 	MessageLoop::RunTask(already_AddRefed<mozilla::Runnable>) 	ipc/chromium/src/base/message_loop.cc:361
13 	xul.dll 	MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask&&) 	ipc/chromium/src/base/message_loop.cc:369
14 	xul.dll 	MessageLoop::DoWork() 	ipc/chromium/src/base/message_loop.cc:444
15 	xul.dll 	base::MessagePumpDefault::Run(base::MessagePump::Delegate*) 	ipc/chromium/src/base/message_pump_default.cc:36
16 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc:231
17 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc:211
18 	xul.dll 	base::Thread::ThreadMain() 	ipc/chromium/src/base/thread.cc:180
19 	xul.dll 	`anonymous namespace'::ThreadFunc 	ipc/chromium/src/base/platform_thread_win.cc:28
20 	kernel32.dll 	BaseThreadInitThunk 	
21 	ntdll.dll 	RtlUserThreadStart

these crashes in the gpu process started appearing in 55.0a1 build 20170603030204.
this would be the changelog to the day before: https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2017-06-02&tochange=43039280fe464869428f03b047bb7c762784f44b
Duplicate of this bug: 1370105
Crash Signature: [@ core::result::unwrap_failed<T> | webrender::renderer::Renderer::draw_tile_frame] → [@ core::result::unwrap_failed<T> | webrender::renderer::Renderer::draw_tile_frame] [@ core::result::unwrap_failed<T> | webrender::renderer::Renderer::submit_batch]
Hi Dzmitry, can you take a look at the crashes? Sounds like they may be related to some of your changes in servo.
Flags: needinfo?(kvark)
This should be fixed in the Jun 6 windows nightly. I'll wait a bit to see if any crashes are reported and close this if not.
Assignee: nobody → bugmail
No more crashes. Fixed by bug 1369152.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.