Bug 1370466 (stylo-wpt)

[meta] stylo: Pass WPT

RESOLVED WORKSFORME

Status

()

P5
normal
RESOLVED WORKSFORME
2 years ago
2 months ago

People

(Reporter: manishearth, Unassigned)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Shing had filed bug 1366972 for Stylo WPT failures. I'll resolve that bug as a duplicate of this one because Manish's test run is more recent and he has already filed some blocking bugs.
Blocks: 1330412
No longer blocks: 1243581
Component: Widget: Gtk → CSS Parsing and Computation
Duplicate of this bug: 1366972
(Reporter)

Comment 3

2 years ago
https://github.com/servo/servo/issues/17181 , https://github.com/servo/servo/issues/17182


(This WPT run is also Shing's, I'm just analyzing the results and fixing things)
(Reporter)

Updated

2 years ago
Depends on: 1364162
(Reporter)

Updated

2 years ago
Depends on: 1370734
P5 because this is a meta bug. Fixing the WPT test failures, though, is obviously a high priority!
Priority: -- → P5
(Reporter)

Updated

2 years ago
Depends on: 1371408
(Reporter)

Updated

2 years ago
Depends on: 1368651
(Reporter)

Updated

2 years ago
Depends on: 1371488
(Reporter)

Updated

2 years ago
No longer depends on: 1368651
Created attachment 8876557 [details]
List of failure

There are 3 big categories: CSSOM, Animation and WebVTT that is failing right now. Not sure if we've paid any attention to WebVTT before.
Flags: needinfo?(cpeterson)
(Reporter)

Comment 6

2 years ago
The CSSOM ones are mostly being fixed by jyc's patches on servo, or were fixed already by me this week.

I haven't really looked at the animation ones.
Animation bugs for web platform test have been tracked in a google document.
Most of failure there will be fixed by bug 1339690, bug 1362897 and bug 1353966.

[1] https://docs.google.com/spreadsheets/d/1iDkLyj06ZnAFynoIRW8uawZsHNS7Fl_ZTO7sbqUDkTE/edit#gid=252449755
Depends on: 1353966, 1362897, 1339690
In yesterday's team meeting, Manish said he would try to enable WPT tests and annotate the expected failures (CSSOM, animations, etc).
Flags: needinfo?(cpeterson)
(Reporter)

Comment 9

2 years ago
just needs james to push patches for bug 1370461
Depends on: 1374028
Depends on: 1374432
Depends on: 1389187
Summary: stylo: Pass WPT → [meta] stylo: Pass WPT
I don't think there's any point in leaving this open.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.